Delimited Text Driver XML input in IDM 4.8.1

I have multiple XML reading delimited text drivers in IDM 4.7 but I cannot get identical driver work with IDM 4.8.1.

It complains "An IOException was thrown in the publisher channel: 'file:/x/temp2.xml': (1): no document element" with a standard XML file with xml header.

I tried feeding it with a text book model document:

<?xml version="1.0" encoding="UTF-8"?><nds dtdversion="4.0" ndsversion="8.x"> <source> <product version="4.8.1.0">DirXML</product> <contact>NetIQ Corporation</contact> </source> <input> <add class-name="User" qualified-src-dn="O=system\CN=h01" src-dn="\XY\system\h01" src-entry-id="9" timestamp="1598583720#108"> <add-attr attr-name="Given Name"> <value timestamp="1598583720#48" type="string">Anu</value> </add-attr> </add> </input> </nds>

 

But still I get a response: An IOException was thrown in the publisher channel: 'file:/xxx/temp.xml': (1): missing end-tag

Did you get any solution to this?

  • Verified Answer

    Solution found. The IDM has latest IDM 4.8.1 service pack installed and there was no delimited text driver patch for 4.8.1 in dl.netiq.com patches.

    But when looking more careful the DT driver version in IDM 4.8.1 is 4.0.2A. And when looking at IDM 4.8 patches from dl.netiq.com there is a patch for DT driver which upgrades it to version 4.0.2.1. Installed it and problem solved.

    A bit misleading to update IDM 4.8.1 driver with a patch found only under 4.8 list.