AzureAD Connector throws a NullPointerException

Hello,

IDM 4.7.1 Remote Loader

AzureAD Connector: 5.1.1.0
REST Connector: 1.0.0.2

I just started with the AzureAD Connector, and it runs fine when I do not enable the Exhange portion. When that bit is enabled, the SHIM gives back a NullPointerException.

DirXML: [08/14/19 09:28:05.68]: TRACE: Azure-AD: Total 0 schema extensions are registered for application a36221cf-8d91-4b5c-8f76-7624346f567e
DirXML: [08/14/19 09:28:05.68]: TRACE: Azure-AD: Populating 0 registered schema extensions in driver schema.
DirXML: [08/14/19 09:28:05.68]: TRACE: Azure-AD: Caught exception during REST Channels initialization.
DirXML: [08/14/19 09:28:05.68]: TRACE: Azure-AD: java.lang.NullPointerException
at com.novell.nds.dirxml.driver.azure.ExchangeAPI$CmdDefinition.access$000(ExchangeAPI.java:554)
at com.novell.nds.dirxml.driver.azure.ExchangeAPI.getSchema(ExchangeAPI.java:529)
at com.novell.nds.dirxml.driver.azure.AZDriverShim.populateFullSchema(AZDriverShim.java:314)
at com.novell.nds.dirxml.driver.azure.AZDriverShim.initRestChannels(AZDriverShim.java:269)
at com.novell.nds.dirxml.driver.azure.AZPublisher.init(AZPublisher.java:117)
at com.novell.nds.dirxml.remote.loader.Driver.run(Driver.java:857)
at java.lang.Thread.run(Thread.java:748)
DirXML: [08/14/19 09:28:05.68]: TRACE: Remote Loader: PublicationShim.init() returned:
DirXML: [08/14/19 09:28:05.68]: TRACE:
<source>
<product build="20190328_1251" instance="Azure-AD" version="5.1.1.0">Identity Manager Driver for Azure AD and Office 365</product>
<contact>NetIQ Corporation</contact>
</source>
<output>
<status level="fatal" type="com.novell.nds.dirxml.driver.azure.StatusException"/>
</output>
</nds>

Has anyone seen this before?  I have going through all the configuration setups, and the WEB service (for Exchange) is working like a champ.

Thanks,

-K