Netiq Dashboard My Profile not displaying

hi,
In IDM Dashboard the My Profile Page is not displaying the user's Roles, Resources and Groups.
However, when searching for users under People-Users all these information are displayed.

Also when logging with the user administrator account i am not allowed to edit a user Object.
However, the user application administrator is granted all permissions.
Any ideas how i can solve this issues?
Parents
  • vkhoury;2492236 wrote:
    hi,
    In IDM Dashboard the My Profile Page is not displaying the user's Roles, Resources and Groups.
    However, when searching for users under People-Users all these information are displayed.

    Also when logging with the user administrator account i am not allowed to edit a user Object.
    However, the user application administrator is granted all permissions.
    Any ideas how i can solve this issues?


    I am having a similar issue with 4.7.1 I believe. I have an open SR on it as well.

    With your users, do you see Roles and Resources? In my case I do not. And the menu labels in the UI are all lowercased, not in title case as they should be. I also found I cannot add or edit a team. Seems like a permissions issue but we have yet to even look at my SR yet so I can't give any insight as to a fix.
Reply
  • vkhoury;2492236 wrote:
    hi,
    In IDM Dashboard the My Profile Page is not displaying the user's Roles, Resources and Groups.
    However, when searching for users under People-Users all these information are displayed.

    Also when logging with the user administrator account i am not allowed to edit a user Object.
    However, the user application administrator is granted all permissions.
    Any ideas how i can solve this issues?


    I am having a similar issue with 4.7.1 I believe. I have an open SR on it as well.

    With your users, do you see Roles and Resources? In my case I do not. And the menu labels in the UI are all lowercased, not in title case as they should be. I also found I cannot add or edit a team. Seems like a permissions issue but we have yet to even look at my SR yet so I can't give any insight as to a fix.
Children
  • tomgreene;2492265 wrote:
    I am having a similar issue with 4.7.1 I believe. I have an open SR on it as well.

    With your users, do you see Roles and Resources? In my case I do not. And the menu labels in the UI are all lowercased, not in title case as they should be. I also found I cannot add or edit a team. Seems like a permissions issue but we have yet to even look at my SR yet so I can't give any insight as to a fix.


    Roles and Resources are not viewed under My Profile, and yes i think it's a permission problem. However, I didn't figure out yet how to give a user the right the view only its own resources and roles.
  • vkhoury;2492331 wrote:
    Roles and Resources are not viewed under My Profile, and yes i think it's a permission problem. However, I didn't figure out yet how to give a user the right the view only its own resources and roles.


    In fact it's a permission problem and you can adjust that by modifying the access permission for users in UA.
    In order to do this you should login as administrator to the user application, then go to settings -> select access and choose User from the Drop Down List.
    Locate the OrgChart and add the user's container to trustees.
    This should solve the issue of displaying user's roles and resources under MyProfile and in Organizational chart.
    However, the user-manager relationship was not displayed (which is really weird).