IDM 4.6 install process JRE Uncomfortable version in RedHat

Hi,

I am installing IDM 4.6 at RedHat 7.3, initially openJDK was installed. I changed to Oracle JDK using below commands, but still facing same issue. IDM/install.sh giving JRE uncomfortable version.

alternatives --install /usr/bin/java java /var/installs/jdk1.8.0_131/bin/java 2
alternatives --config java
selection

alternatives --install /usr/bin/javac javac /var/installs/jdk1.8.0_131/bin/javac 2
alternatives --install /usr/bin/jar jar /var/installs/jdk1.8.0_131/bin/jar 2
alternatives --set jar /var/installs/jdk1.8.0_131/bin/jar
alternatives --set javac /var/installs/jdk1.8.0_131/bin/javac

I tried JRE Lower version too
java version "1.8.0_65"
Java(TM) SE Runtime Environment (build 1.8.0_65-b17)
Java HotSpot(TM) 64-Bit Server VM (build 25.65-b01, mixed mode)

Any Idea on RedHat....
  • On 06/27/2017 08:04 AM, c-pkalla wrote:
    >
    > I am installing IDM 4.6 at RedHat 7.3, initially openJDK was installed.
    > I changed to Oracle JDK using below commands, but still facing same
    > issue. IDM/install.sh giving JRE uncomfortable version.


    I presume you mean the IDM engine, though specifying may help.

    What does "giving JRE uncomfortable version" mean? I've never heard of
    that error; it would help if you posted exact output from something
    erroring so we can decipher it directly. If not already answered, please
    explain why you are trying to change the JRE in the first place.

    IDM comes with its own JRE, and it is not meant to be used, or ever used
    by default, with the rest of the system, so the 'alternatives' bit you are
    trying to update does not make sense. IDM will not use any system-wide
    JREs unless you really force it, in which case you'll probably break it
    too. IDM's JRE is located under
    /opt/novell/eDirectory/lib64/nds-modules/jre which is a symlink to the
    actual directory, and you should not touch it as it will work out of the
    box, leaving the rest of your system alone to have Java or not in
    whichever form you prefer.

    --
    Good luck.

    If you find this post helpful and are logged into the web interface,
    show your appreciation and click on the star below.

    If you want to send me a private message, please let me know in the
    forum as I do not use the web interface often.
  • [root@XXXXXXX IDM]# ./install.bin
    linux/setup/idm_linux.bin -i console
    Preparing to install
    Extracting the JRE from the installer archive...
    Unpacking the JRE...
    Extracting the installation resources from the installer archive...
    Configuring the installer for this system's environment...

    Launching installer...

    JRE libraries are missing or not compatible....
    Exiting....
  • That's....... weird. Did you verify the media after downloading in case
    the checksum (usually md5sum) does not match due to corruption? If you
    burned the media to media did you verify that as well?

    Otherwise, my next-best guess is that your OS is preventing running the
    installer's JRE (the installer comes with its own JRE, completely separate
    from anything; don't worry about needing that either as Micro Focus
    provides everything out of the box so you do not need to work so hard)
    from wherever it was extracted. For example, if /tmp is mounted as noexec
    then anything extracted there (as I believe the installer, with its JRE,
    is) then that will not run, and perhaps that is being detected as the
    problem below.

    Post the output to the following command, please:


    mount



    --
    Good luck.

    If you find this post helpful and are logged into the web interface,
    show your appreciation and click on the star below.

    If you want to send me a private message, please let me know in the
    forum as I do not use the web interface often.
  • [root@XXXXXXXX IDM]# mount
    sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime,seclabel)
    proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
    devtmpfs on /dev type devtmpfs (rw,nosuid,seclabel,size=1917280k,nr_inodes=479320,mode=755)
    securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
    tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev,seclabel)
    devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,seclabel,gid=5,mode=620,ptmxmode=000)
    tmpfs on /run type tmpfs (rw,nosuid,nodev,seclabel,mode=755)
    tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,seclabel,mode=755)
    cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/usr/lib/systemd/systemd-cgroups-agent,name=systemd)
    pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
    cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpuacct,cpu)
    cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
    cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
    cgroup on /sys/fs/cgroup/net_cls,net_prio type cgroup (rw,nosuid,nodev,noexec,relatime,net_prio,net_cls)
    cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
    cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
    cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
    cgroup on /sys/fs/cgroup/hugetlb type cgroup (rw,nosuid,nodev,noexec,relatime,hugetlb)
    cgroup on /sys/fs/cgroup/pids type cgroup (rw,nosuid,nodev,noexec,relatime,pids)
    cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_event)
    configfs on /sys/kernel/config type configfs (rw,relatime)
    /dev/mapper/rhel-root on / type xfs (rw,relatime,seclabel,attr2,inode64,noquota)
    selinuxfs on /sys/fs/selinux type selinuxfs (rw,relatime)
    systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=32,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
    hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime,seclabel)
    debugfs on /sys/kernel/debug type debugfs (rw,relatime)
    mqueue on /dev/mqueue type mqueue (rw,relatime,seclabel)
    nfsd on /proc/fs/nfsd type nfsd (rw,relatime)
    /dev/sda2 on /boot type xfs (rw,relatime,seclabel,attr2,inode64,noquota)
    /dev/mapper/vgpool-opt on /opt type xfs (rw,relatime,seclabel,attr2,inode64,noquota)
    /dev/mapper/rhel-var on /var type xfs (rw,relatime,seclabel,attr2,inode64,noquota)
    sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw,relatime)
    tmpfs on /run/user/10002 type tmpfs (rw,nosuid,nodev,relatime,seclabel,size=386556k,mode=700,uid=10002,gid=10002)
    binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,relatime)
    tmpfs on /run/user/0 type tmpfs (rw,nosuid,nodev,relatime,seclabel,size=386556k,mode=700)
    gvfsd-fuse on /run/user/0/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=0,group_id=0)
    fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
    /dev/sr0 on /run/media/root/IDM4.6_Lin type iso9660 (ro,nosuid,nodev,relatime,uid=0,gid=0,iocharset=utf8,mode=0400,dmode=0500,uhelper=udisks2)
  • How about disk free space everywhere?


    df -h


    --
    Good luck.

    If you find this post helpful and are logged into the web interface,
    show your appreciation and click on the star below.

    If you want to send me a private message, please let me know in the
    forum as I do not use the web interface often.
  • Disk space good, I re-run the ./II-rhel-Prerequisite.sh
    It is not installed properly with option -y : yum -y install "$PKG"
    yum --nogpgcheck install "$PKG"

    After installed all RPM's, working as expected.
    Thanks for Help.
  • Care to share what was missing to help others needing the same prerequisites?


    rpm -qa --last | head -30



    --
    Good luck.

    If you find this post helpful and are logged into the web interface,
    show your appreciation and click on the star below.

    If you want to send me a private message, please let me know in the
    forum as I do not use the web interface often.
  • To install the required packages for Identity Manager on RHEL7.x, create an install.sh file and add the following contents to the file:

    #!/bin/bash
    yum clean all
    yum repolist
    yum makecache

    PKGS="ksh gettext.x86_64 libXrender.i686 libXau.i686 libxcb.i686 libX11.i686 libXext.i686 libXi.i686 libXtst.i686 glibc.x86_64 libstdc .i686 libstdc .x86_64 libgcc.x86_64"

    for PKG in $PKGS;
    do
    yum --nogpgcheck install "$PKG"
    done
  • On 27.06.17 19:34, c-pkalla wrote:
    >
    > To install the required packages for Identity Manager on RHEL7.x, create
    > an install.sh file and add the following contents to the file:
    >
    > #!/bin/bash
    > yum clean all
    > yum repolist
    > yum makecache
    >
    > PKGS="ksh gettext.x86_64 libXrender.i686 libXau.i686 libxcb.i686
    > libX11.i686 libXext.i686 libXi.i686 libXtst.i686 glibc.x86_64
    > libstdc .i686 libstdc .x86_64 libgcc.x86_64"
    >
    > for PKG in $PKGS;
    > do
    > yum --nogpgcheck install "$PKG"
    > done



    I used this for RHEL 7.3:

    # subscription-manager register —username <username> --password
    <password> —autosubscribe
    # rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release
    # yum install yum-utils
    # yum-config-manager --enable rhel-7-server-optional-rpms
    # PKGS="ksh gettext libXrender.i686 libXau.i686 libxcb.i686 libX11.i686
    libXext.i686 libXi.i686 libXtst.i686 glibc.i686 libstdc .i686
    libgcc.i686 compat-libstdc -33.i686 compat-libstdc -33.x86_64
    gperftools-libs.i686 gperftools-libs.x86_64"
    # yum -y install $PKGS


    I think you're first error (first message) could be some missing
    packages, verify with the above - I found that the gpertools which comes
    with eDirectory is not compatible with RHEL - which is why I installed
    the one from RHEL - and it worked.

    You can launch the install with:


    # export LAX_DEBUG=true
    --> run installer

    That will provide you with lots more information.


    Casper

  • cpedersen;2460615 wrote:
    On 27.06.17 19:34, c-pkalla wrote:
    >
    > To install the required packages for Identity Manager on RHEL7.x, create
    > an install.sh file and add the following contents to the file:
    >
    > #!/bin/bash
    > yum clean all
    > yum repolist
    > yum makecache
    >
    > PKGS="ksh gettext.x86_64 libXrender.i686 libXau.i686 libxcb.i686
    > libX11.i686 libXext.i686 libXi.i686 libXtst.i686 glibc.x86_64
    > libstdc .i686 libstdc .x86_64 libgcc.x86_64"
    >
    > for PKG in $PKGS;
    > do
    > yum --nogpgcheck install "$PKG"
    > done



    I used this for RHEL 7.3:

    # subscription-manager register —username <username> --password
    <password> —autosubscribe
    # rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release
    # yum install yum-utils
    # yum-config-manager --enable rhel-7-server-optional-rpms
    # PKGS="ksh gettext libXrender.i686 libXau.i686 libxcb.i686 libX11.i686
    libXext.i686 libXi.i686 libXtst.i686 glibc.i686 libstdc .i686
    libgcc.i686 compat-libstdc -33.i686 compat-libstdc -33.x86_64
    gperftools-libs.i686 gperftools-libs.x86_64"
    # yum -y install $PKGS


    I think you're first error (first message) could be some missing
    packages, verify with the above - I found that the gpertools which comes
    with eDirectory is not compatible with RHEL - which is why I installed
    the one from RHEL - and it worked.

    You can launch the install with:


    # export LAX_DEBUG=true
    --> run installer

    That will provide you with lots more information.


    Casper


    I had to add compat-libstdc -33.i686 to the list of packets as well. I am using CentOS 7 but it is identical to RHEL.

    I did not find the required packages from the setup documents. Or I somehow missed it.