Trouble with Activity REST


Hello,I need help with this please!

we are trying to connect to a Web Service using the activity REST in a
Workflow and we get the following error:

* Activity User Comments
Rest IDMProv Workflow Error: Error initializing scripting
engine or scripting context
*


how could i get a more descriptive error? or how could i debug it to see
what is happening?

we are using 4.0.2 IDM version.

If you need more information, let me know

Thanks,

Best regards


--
lpartescano
------------------------------------------------------------------------
lpartescano's Profile: https://forums.netiq.com/member.php?userid=9067
View this thread: https://forums.netiq.com/showthread.php?t=55822

  • Typically this is caused by an exception in the parameters that you you
    hand over to the REST activity.

    Try adding a log activity before making your REST call, displaying your
    input parameters - wrapped in try..catch - and showing whatever
    exception is thrown. That should guide you into the right direction.

    Sample causes may include plain syntax errors or trying to call
    GCV.getNamedPassword() when permissions are not set correctly.

    Good luck
    Wolfgang

    On 06.05.2016 18:04, lpartescano wrote:
    >
    > Hello,I need help with this please!
    >
    > we are trying to connect to a Web Service using the activity REST in a
    > Workflow and we get the following error:
    >
    > * Activity User Comments
    > Rest IDMProv Workflow Error: Error initializing scripting
    > engine or scripting context
    > *
    >
    >
    > how could i get a more descriptive error? or how could i debug it to see
    > what is happening?
    >
    > we are using 4.0.2 IDM version.
    >
    > If you need more information, let me know
    >
    > Thanks,
    >
    > Best regards
    >
    >