CACHE ERROR>Error: Could not find or load main class com.novell.naudit.lcache.LCache

USER App 4.0.2 with IDM home page and HPD-Patch1.
I am getting the following error:CACHE ERROR>Error: Could not find or
load main class com.novell.naudit.lcache.LCache

Auditing was never turned on when this system was built.

How do I turn off auditing without having to reinstall the userapp?
  • Have you looked at the /etc/logevent.conf file by chance? The default
    file is, unfortunately, configured to enable auditing to an unlikely host
    (127.0.0.1); basically the default is less-than-desirable, and perhaps
    patching re-enabled that. If so, you may have an
    /etc/logevent.conf.rpmsave file with old settings.

    --
    Good luck.

    If you find this post helpful and are logged into the web interface,
    show your appreciation and click on the star below...
  • On 12/15/2014 11:14 AM, ab wrote:
    > Have you looked at the /etc/logevent.conf file by chance? The default
    > file is, unfortunately, configured to enable auditing to an unlikely host
    > (127.0.0.1); basically the default is less-than-desirable, and perhaps
    > patching re-enabled that. If so, you may have an
    > /etc/logevent.conf.rpmsave file with old settings.
    >

    Greetings,

    I did not design the 4.0.2A updater to enable auditing. It is actually
    called out in the documentation:

    https://www.netiq.com/documentation/idm402/idmhomepage/data/b18rmsde.html

    "
    When you run the Updater utility (IdmHPD.bin), the utility replaces your
    existing logging configuration files for the User Application and
    Reporting Module (if installed). The utility sets all logging settings
    back to the default configuration when the User Application or Reporting
    Module were first installed. In addition, the utility disables Auditing
    by default.
    "


    You are receiving this message because the value for the
    "LogJavaClassPath" in the logevent.conf file in the /etc folder does not
    have the correct entry to where the NAuditPA.jar is located. Or, the
    user running the Application Server does not have permissions to the
    file. The entry to the file must include the jar itself

    For Example:

    LogJavaClassPath=/opt/novell/idm/rbpm/UserApplication/NAuditPA.jar


    If you truly are not going to use Auditing then you can double check
    your environment:


    A) To double check the User Application

    1) login to the UserApp as the admin
    2) Go to Administration -> Application Configuration sub tab -> Logging
    3) Is there a checkbox next to either of the following:
    "Enable audit service"
    "Enable OpenXDAS"

    If there is, uncheck them, check the checkbox next to " Persist the
    logging changes", and then press the submit button.

    4) It is not necessary, but I would recommend restarting the Application
    Server.


    B) To double check Reporting Module
    1) On this page:
    https://www.netiq.com/documentation/idm402/idmhomepage/data/b18rmsde.html

    We outline how to enable auditing for Reporting. If this step was done,
    then reverse the steps and restart the Application Server.


    --

    Sincerely,
    Steven Williams
    Lead Software Engineer
    NetIQ