Wrong protocol and port in Mail Notifications

Hi, me again :)

I have noticed, that in email notifications (I will use Provisioning Notification as example) the generated task URLs have wrong protocol and port, as a result, they do not work when clicked on by user.

It looks like this:

Hi,

A new provisioning request has been submitted that requires your approval.

Request name: Test Single Approval
Submitted by: User Application Admin uaadmin
Recipient: UserA

Please review the details of this request at acme.com:8180/.../approvalForm.do to take the appropriate action.

You can review a list of all requests pending your approval at acme.com:8180/.../



I expect it to be https://acme.com:8543


The default template is defined like this: $PROTOCOL$://$HOST$:$PORT$/$TASK_DETAILS$


I would like to know, where to change what and why is it like this, when everything is configured with https and works just fine.

I am sure I can hardcode it into template, but that does not feel right :)
  • On 7/20/17 10:16 AM, dragonslord wrote:
    >
    > Hi, me again :)
    >
    > I have noticed, that in email notifications (I will use Provisioning
    > Notification as example) the generated task URLs have wrong protocol and
    > port, as a result, they do not work when clicked on by user.
    >
    > It looks like this:
    >
    > Code:
    > --------------------
    >
    > Hi,
    >
    > A new provisioning request has been submitted that requires your approval.
    >
    > Request name: Test Single Approval
    > Submitted by: User Application Admin uaadmin
    > Recipient: UserA
    >
    > Please review the details of this request at http://acme.com:8180/IDMProv/approvalForm.do?weId=97a276df753445db9blablabla to take the appropriate action.
    >
    > You can review a list of all requests pending your approval at http://acme.com:8180/idmdash/#/tasks.
    >
    > --------------------
    >
    >
    >
    > I expect it to be https://acme.com:8543
    >
    >
    > The default template is defined like this:
    > $PROTOCOL$://$HOST$:$PORT$/$TASK_DETAILS$
    >
    >
    > I would like to know, where to change what and why is it like this, when
    > everything is configured with https and works just fine.
    >
    > I am sure I can hardcode it into template, but that does not feel right
    > :)
    >
    >

    Greetings,
    You need to update the tokens in configupdate. I do believe this is
    discussed in the documentation.

    --
    Sincerely,
    Steven Williams
    Principal Enterprise Architect
    Micro Focus
  • What tokens? I believe there is nothing more to update in configupdate:




    This was already set. Should I set Template Protocol and Template Secure Protocol to the same secure values?
  • On 7/21/17 3:54 AM, dragonslord wrote:
    >
    > What tokens? I believe there is nothing more to update in configupdate:
    >
    > 5893
    >
    >
    > This was already set. Should I set Template Protocol and Template Secure
    > Protocol to the same secure values?
    >
    >
    > ----------------------------------------------------------------------
    > |Filename: yq6ZnnZ.png |
    > |Download: https://forums.novell.com/attachment.php?attachmentid=5893 |
    > ----------------------------------------------------------------------
    >

    Greetings,
    You have two(2) options:

    #1
    Go into the email templates in Designer and change each one to use the
    tokens $SECURE_PORT$ instead of $PORT$ and $SECURE_PROTOCOL$ instead of
    $PROTOCOL$

    Save and deploy them all back to the Vault

    OR

    #2
    Change the values in configupdate so that the none-secure values are the
    secure values. Save and restart the Application server.



    --
    Sincerely,
    Steven Williams
    Principal Enterprise Architect
    Micro Focus