IDM 3.6.1 installation on Linux OS with special characters('$','#') in password

0 Likes
over 10 years ago
I was installing IDM 3.6.1 on SUSE Linux Enterprise Server 10 SP2 for production environment at my customer site. After the installation I was not able to create DriverSet object. I checked the installation log files and found ArrayIndexOutOfBounds errors that are related to schema extensions. Installation went fine in development, testing and QA environment. There is no difference between the hardware and software in those environments.

What could be the problem? When compared carefully I found that the eDirectory admin password is different. In development, testing and QA environment I was using a eDirectory admin password that has a special character '@' in it. In the production environment installation I was using a special character '$' in the eDirectory admin password. I changed the eDirectory admin password in production environment to match development, testing and QA environment and that's it the installation went smooth.

After some tests I found that on Linux OS, IDM 3.6.1 installation has issues with special characters in eDirectory admin passwords. Based on my tests the eDirectory admin password cannot contain at least '$' and '#' special characters in it. However this is not a problem on windows environment.

In conclusion avoid special characters('$','#') for eDirectory admin passwords on Linux OS to install IDM successfully.

Labels:

How To-Best Practice
Comment List
Anonymous
Related Discussions
Recommended