This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

LDAP requirements for IG 3.7

Hi

According to the requirements in https://www.microfocus.com/documentation/identity-governance/3.7/requirements/requirements.html the LDAP Identity Service must be "Microsoft Active Directory that comes with Windows Server 2019". 

Is it really true that it works only with an AD running on Server 2019? AFAIK Windows Server 2016 is still supported (ok, extended support) until 2027 and we won't update anytime soon... but the users of course want to log into IG with their usual windows credentials. I can't imagine we have to keep IG 3.6.2 for the next 4 years...

Thanks for some explanation!

Fabian

  • will be authoritativeon the answer.  Which probably depends on whether tehy are looking for a specific Schema or function in 2019 missing in 2016.  But I suspect they are referring to AD Schema, Forest and Domain levels.  Not specifically the Windows version, rather the functionality of AD.  Can Window 2016 AD run in a tree that is at the 2019 forest level?

  • It's just for authentication, so we are in fact only referring to the AD level. As far as I would expect there shouldn't be that much changes, in the end it's still just an LDAP-query. But that's exactly why I wonder it's written AD that comes with Server v2019. 

  • Verified Answer

    Hello,
       The version of Active Directory listed in the 3.7.3 documentation is the version that was tested and certified against. It is possible that an earlier version of AD could work correctly, but it was not tested and therefore would not be support or certified.

      Please be aware that Identity Governance 3.6.1 is no longer "supported" and 3.6.2 (3.6.2.5) is only "supported" until 31-March-2023. I would strongly recommend upgrading to 3.7.3 as quick as possible. For version 3.7.3, we only support upgrading from version 3.7.0 or 3.6.2 (3.6.2.5). If you are still on version 3.6.1 (per one of your other posts where you outlined that version 3.6.1 is being utilized), moving to 3.7.3 would require two (2) updates: 3.6.1 -> 3.6.2 -> 3.7.3 or 3.6.1 -> 3.7.0 -> 3.7.3

    Sincerely,
    Steven Williams
    Principal Enterprise Architect
    Micro Focus

  • Thanks, in fact we're still on 3.6.1... we will update asap.