Cybersecurity
DevOps Cloud (ADM)
IT Operations Cloud
Summary
Unable to open a Form because IgaFormRenderer process is not running
Products
Identity Manager (IDM)
Environment
Identity Manager 4.8.x
Situation
/opt/netiq/common/nginx/logs/error.log shows following error mesage
2023/02/02 12:29:37 [error] 64712#0: *5 connect() failed (111: Connection refused) while connecting to upstream,
client: <ip-address>, server: <hostname>:8600, request: "GET /ngsw-worker.js
HTTP/1.1", upstream: "http://127.0.0.1:3000/ngsw-worker.js"" , host: "<hostname>:8600", referrer: "https://<hostname>:8600/forms/""
Cause
This caused by the fact that the IgaFormRenderer process is not running and nothing is listening on port 3000
which is missing in the startup script.
#netstat -napl|grep -e 3000 -e 8600
tcp 0 0 0.0.0.0:8600 0.0.0.0:* LISTEN 64682/nginx
Resolution
Edit the /etc/init.d/netiq-golang.sh script verify that port 3000 is present as below.
start)
str1=`gettext install "Starting IGA form renderer backend."`
echo $str1
ulimit -n 1024
(/opt/netiq/idm/apps/sites/IgaFormRenderer.sh -config /opt/netiq/idm/apps/sites/config.ini -golangPort 3000 start &> /dev/null) &
;;
stop)
str1=`gettext install "Stopping IGA form renderer backend"`
echo $str1
kill $(lsof -t -i:3000) &> /dev/null
;;
*)
echo "Hello web app service."
echo $"Usage $0 {start|stop}"
exit 1
Restart the nginx service and verify that port 3000 is listening and IgaFormRenderer is running.
#systemctl restart netiq-nginx.service
#netstat -napl|grep -e 3000 -e 8600
tcp 0 0 0.0.0.0:8600 0.0.0.0:* LISTEN 76725/nginx
tcp 0 0 :::3000 :::* LISTEN 76784/IgaFormRender
#ps -ef|grep 3000
novlua 76784 1 0 12:48 ? 00:00:00 /opt/netiq/idm/apps/sites/IgaFormRenderer.sh
-config /opt/netiq/idm/apps/sites/config.ini -golangPort 3000 start
URL Name
KM000013831