Errors when accessing a service in Identity Console

I have installed the Container version of Identity Console 1.3.0 in one of my clients servers. 

The Docker container is running without any problem and I can login successfully into the Identity Console home page. 

The problem comes when I try to access to any of the services available, I checked the Google Chrome client logs and I obtained couple errors that i attach in this post. 

Reading the logs, I suppose that these errors are related to some source code issues.

I didn't find anything about these issues, so please if anyone knows something related to these errors, reply to this post to help me find the problem. 

Parents
  • Try to check the IDConsole edirapi.log, usually here:

    /var/lib/docker/volumes/IDConsole-volume/_data/eDirAPI/var/log

    Do you see any errors?

    Have you set the correct origin in the edirapi.conf?

  • Hello! Thanks for replying alekz. 

    I checked the edirapi.log and I saw this error multiple times: Unable to read server specific data:LDAP Result Code 2 \"Protocol Error\": Unrecognized extended operation

    These errors appear when I try to access to one of the services, it doesen't happen with all the services, just in some of them. 

    For the other part I checked if the origin in the edirapi.conf (for me it is identityconsole.conf because I created another file to not to overwrite the sample one) and the origin was correct. Otherwise, I changed the check-origin parameter to false and nothing changed. 

    So I'm a bit upset because I cannot identify the problem with accuracy. 
    I have a supposition that maybe these errors can come for the certificate, I saw something about that in the container-startup.log. But I'm not sure. 

     

    So please if you know something about the LDAP error I mentioned in this reply, let me know. 

    Thank you for the attention! :) 

Reply
  • Hello! Thanks for replying alekz. 

    I checked the edirapi.log and I saw this error multiple times: Unable to read server specific data:LDAP Result Code 2 \"Protocol Error\": Unrecognized extended operation

    These errors appear when I try to access to one of the services, it doesen't happen with all the services, just in some of them. 

    For the other part I checked if the origin in the edirapi.conf (for me it is identityconsole.conf because I created another file to not to overwrite the sample one) and the origin was correct. Otherwise, I changed the check-origin parameter to false and nothing changed. 

    So I'm a bit upset because I cannot identify the problem with accuracy. 
    I have a supposition that maybe these errors can come for the certificate, I saw something about that in the container-startup.log. But I'm not sure. 

     

    So please if you know something about the LDAP error I mentioned in this reply, let me know. 

    Thank you for the attention! :) 

Children
  • Do you have the correct version of eDirectory and IDM?

    Identity Console 1.3 supports eDirectory 9.2.4 HF2 and Identity Manager Engine 4.8.3 HF2. You must upgrade your eDirectory and Identity Manager Engine instances before using with this version of Identity Console.

  • I checked the eDirectory and Identity Manager Engine and I have the eDirectory 9.2.5 and the Identity Manager Engine 4.8.0.1. 

    I will update Identity Manager Engine to satisfy the requirements, but there are Identity Console services that doesn't work and they're not related to the Drivers. 

    Do you think the Identity Manager Engine version, it's affecting in a bigger way than not just applying for the services related to Identity Manager? 

  • Don't know. The LDAP extension error is probably because you are missing the extensions that were added by IDM 4.8.3. It might be that those other errors are a result because of that. You'll just have to test and see.

    What other services in IC don't work?

  • Hello again Alekz. 

    I'll update my actual status related to IC. 

    I had updated the Identity Manager Engine to 4.8.4 version and now there are more services working, but not all of them. 
    I made a screenshot to visualize the services running without problem (green), the services with some features that don't work (orange) and services which, when I access to them displays a white screen and get stuck (red). 


    I see that the services in red are related to objects in the directory, and the orange ones show the drivers but doesn't display the status of them. That's weird because in the "Estadísticas del conjunto de controladores" (Controller Set Statistics) I can see all the drivers status... 

    Thank you! 

  • I think you should open a SR unless someone else here has any other ideas.

    I can't say why some services are working and others are not.

  • It seems that some required LDAP extensions are missing from the tree. You can confirm it by looking at LDAP logs(ndstrace->LDAP). As others have suggested, it would be best to open a support ticket.