AzureAD driver is not starting - Exchange online server error

Hi Experts,

I have upgraded the Azure AD drive from 5.1.5  to 5.1.5.0100. After the upgrade the driver is working fine for the past one week. But today the driver isn't coming up and getting the below error,

DirXML Log Event -------------------
     Driver:   \IDVAULT\system\driverset1\Azure AD
     Channel:  Publisher
     Object:   null(\IDVAULT\system\driverset1\Azure AD)
     Status:   Fatal
     Message:  Code(-9005) The driver returned a "fatal" status indicating that the driver should be shut down. Detail from driver: Exchange: com.novell.nds.dirxml.driver.azure.exceptions.ChannelException: &lt;?xml version="1.0" encoding="utf-8"?>&lt;!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">&lt;html xmlns="http://www.w3.org/1999/xhtml">  &lt;head>    &lt;title>Request Error&lt;/title>    &lt;style>BODY { color: #000000; background-color: white; font-family: Verdana; margin-left: 0px; margin-top: 0px; } #content { margin-left: 30px; font-size: .70em; padding-bottom: 2em; } A:link { color: #336699; font-weight: bold; text-decoration: underline; } A:visited { color: #6699cc; font-weight: bold; text-decoration: underline; } A:active { color: #336699; font-weight: bold; text-decoration: underline; } .heading1 { background-color: #003366; border-bottom: #336699 6px solid; color: #ffffff; font-family: Tahoma; font-size: 26px; font-weight: normal;margin: 0em 0em 10px -20px; padding-bottom: 8px; padding-left: 30px;padding-top: 16px;} pre { font-size:small; background-color: #e5e5cc; padding: 5px; font-family: Courier New; margin-top: 0px; border: 1px #f0f0e0 solid; white-space: pre-wrap; white-space: -pre-wrap; word-wrap: break-word; } table { border-collapse: collapse; border-spacing: 0px; font-family: Verdana;} table th { border-right: 2px white solid; border-bottom: 2px white solid; font-weight: bold; background-color: #cecf9c;} table td { border-right: 2px white solid; border-bottom: 2px white solid; background-color: #e5e5cc;}&lt;/style>  &lt;/head>  &lt;body>    &lt;div id="content">      &lt;p class="heading1">Request Error&lt;/p>      &lt;p>The server encountered an error processing the request. See server logs for more details.&lt;/p>    &lt;/div>  &lt;/body>&lt;/html><application>DirXML</application>
<module>Azure AD</module>
<object-dn>null(\IDVAULT\system\driverset1\Azure AD)</object-dn>
<component>Publisher</component>
[11/30/22 16:38:10.331]:Azure AD PT:Killing driver from publisher thread; after PublicationShim.start().
[11/30/22 16:38:10.333]:Azure AD PT:Requesting termination.
[11/30/22 16:38:10.336]:Azure AD PT:Ending publisher thread.
[11/30/22 16:38:10.366]:Azure AD ST:Leaving event loop.
[11/30/22 16:38:10.367]:Azure AD ST:Shutting down DirXML driver \IDVAULT\system\driverset1\Azure AD.
[11/30/22 16:38:10.368]:Azure AD ST:No shutdown policies.
[11/30/22 16:38:10.369]:Azure AD ST:Remote Interface Driver: Notifying publisher to shutdown.
[11/30/22 16:38:10.370]:Azure AD ST:DriverShim.shutdown() returned:
[11/30/22 16:38:10.371]:Azure AD ST:
<nds dtdversion="4.0" ndsversion="8.x">
  <output>
    <status level="success"/>
  </output>
</nds>
[11/30/22 16:38:10.371]:Azure AD ST:Waiting for Publisher thread to terminate. Maximum wait time is 60 seconds.
[11/30/22 16:38:10.371]:Azure AD ST:Publisher thread terminated.
[11/30/22 16:38:10.372]:Azure AD ST:MapHandler: Closing MapHandler 'com.microfocus.database.zoomdb.hashmap.HashMapHandler@VARS'.
[11/30/22 16:38:10.372]:Azure AD ST:MapImpl: Closed MapImpl 'com.microfocus.database.zoomdb.hashmap.HashMapImpl@VARS' with handle '274132736'.
[11/30/22 16:38:10.372]:Azure AD ST:MapHandler: Closing MapHandler 'com.microfocus.database.zoomdb.hashmap.HashMapHandler@REPM'.
[11/30/22 16:38:10.374]:Azure AD ST:MapImpl: Closed MapImpl 'com.microfocus.database.zoomdb.hashmap.HashMapImpl@REPM' with handle '597219184'.
[11/30/22 16:38:10.376]:Azure AD ST:MapHandler: Closing MapHandler 'com.microfocus.database.zoomdb.hashmap.HashMapHandler@WORKQ'.
[11/30/22 16:38:10.378]:Azure AD ST:MapImpl: Closed MapImpl 'com.microfocus.database.zoomdb.hashmap.HashMapImpl@WORKQ' with handle '576071984'.
[11/30/22 16:38:10.381]:Azure AD ST:Driver terminated.
[11/30/22 16:38:10.382]:Azure AD ST:Writing XML attribute vnd.nds.stream://IDVAULT/system/driverset1/Azure+AD#DirXML-PersistentData.

I've tried the following method to fix the issue:

  1. Restarted the IDM exchange online service in the remote loader
  2. Restarted the RL instance for AzureAD remote loader
  3. Restarted the RRL server
  4. Removed the cache from the AzureAD driver and restarted it
  5. Restarted the eDirectory
  6. Deleted the zoomdb file for the AzureAD driver in the following path /var/opt/novell/eDirectory/data/dib/dx100036.zoomdb

After doing all the above steps, still the Azure AD driver is on stopped state and not coming up..

We tried to replace the exchange server related dll file in the remote loader server based on this Azure AD readme file - https://www.netiq.com/documentation/identity-manager-48-drivers/AzureADDriver_5150100readme/data/AzureADDriver_5150100readme.html

If we restart the Exchange server we getting No connection to remote loader and if we restart the RL service for Azure AD then we getting the issue related to Exchange online server and vice versa

Could anyone  please help me to fix the issue??

Any help much appreciated!!