Support Tip: Upgrade to SLES 15 SP3 breaks eDirectory 9.2.x and IDM 4.8.x on the server

0 Likes

Update to SLES 15 SP3 breaks eDirectory 9.2.x and IDM 4.8.x on the server

Summary

Update to SLES 15 SP3 breaks eDirectory 9.2.x and IDM 4.8.x on the server

URL Name

KM000002989

Products

Identity Manager (IDM)

Article Body
Environment
SLES 15 SP3
Identity Manager 4.8.4
Identity Manager 4.8.x

Situation
After upgrading from SLES 15 SP2 to SLES 15 SP3, eDirectory does not load and Identity Manager (IDM) is no longer working on the server

Cause
For some reason the SLES upgrade is removing some of the required RPM's for eDirectory.   So eDirectory will no longer start on the server.
novell-edirectory-xdaslog-9.2.3-0.x86_64.rpm
novell-edirectory-xdaslog-conf-9.2.4-0.noarch.rpm
novell-edirectory-cefinstrument-9.2.5-0.x86_64.rpm

Resolution
Using the install files from the current version of eDirectory installed, run a "nds-install -f"
For example if you have IDM 4.8.4 installed on the server, from the extracted IDM 4.8.4 install files, run IDVault\setup\nds-install -f

Then reboot the server and verify eDirectory loads and your IDM drivers are now running. 

__________________________________

Elizabeth Knappen
CyberRes Community Manager

If this answered your question, please mark it as "Suggest as Answer" or "Verify as Answer".
If you found this post useful, please give it a "Like".

Labels:

Support Tip
Comment List
Anonymous
Related Discussions
Recommended