Knowledge Doc: SCIM Driver won't Start - UnsupportedOperationException: This class does not support JDK1.5

0 Likes

Summary
SCIM Driver won't start after applying IDM 4.8.5 update. UnsupportedOperationException: This class does not support JDK1.5

Products
Identity Manager (IDM)

Environment
Identity Manager 4.8.5
Identity Manager SCIM Driver 1.0.1.0200

Situation
SCIM Driver won't start after applying IDM 4.8.5 update.

Driver: \SCIM Driver
Channel: Publisher
Status: Error
Message: Code(-9010) An exception occurred: java.lang.UnsupportedOperationException: This class does not support JDK1.5
at weblogic.xml.jaxp.RegistryTransformerFactory.setFeature(RegistryTransformerFactory.java:317)
at com.microfocus.nds.dirxml.driver.scim.SCIMCommonImpl.convertDocumentToString(SCIMCommonImpl.java:127)
at com.microfocus.nds.dirxml.driver.scim.SCIMPublisher.setDirXmlStorage(SCIMPublisher.java:334)
at com.microfocus.nds.dirxml.driver.scim.SCIMPublisher.start(SCIMPublisher.java:205)
at com.novell.nds.dirxml.engine.Publisher.run(Publisher.java:607)
at java.lang.Thread.run(Thread.java:748)

Cause
A very old JAR file was found in the IDM classes folder that was not a standard JAR file for IDM. It was interfering with the SCIM driver.

Resolution
Removed the old JAR file and restarted eDirectory

Support Article Link

Support Article Reference Number (URL Name)
KM000005443

Labels:

Knowledge Docs
Comment List
Related
Recommended