Faile to browser remote resource

Hi

 

I'm new to CG product and recently install CG 6.0 with agent on Win 10, while using policy editor to browser agent resource an error will pup-up and behavior will stop.

The error argues for unable to load DLL 'idcdwrapper.dll' exception.

Does anyone have a suggestion for this?

c.pngb.png

#CG 6.0 #PE Error
  • can you ping the IP address from the CG server.  Have confirmed that the agent is still running?  Is it just this agent or is it happening for all agents?  

  • Hi alkamm,

     

    Thanks for your reach out, this error happens on all agents.

    1. Ping target server (iiq73 and rh79) from CG server :
      • cg:~ # ping iiq73
      • PING iiq73.demo.infoarchi.com (10.8.8.9) 56(84) bytes of data.
      • 64 bytes from iiq73.demo.infoarchi.com (10.8.8.9): icmp_seq=1 ttl=128 time=0.349 ms
      • cg:~ # ping rh79.demo.infoarchi.com
      • PING rh79.demo.infoarchi.com (10.8.8.15) 56(84) bytes of data.
      • 64 bytes from rh79.demo.infoarchi.com (10.8.8.15): icmp_seq=1 ttl=64 time=0.247 ms
      • cg:~ #
    2. Have confirmed that the agent is still running?
    • rh79 -> YES,  by check the log on rh79
    • Iiq 73 -> YES, by check the service status on Win 10 service management.msc
    • The status of agent on WEBGUI also show all agents are active.
    1. Is it just this agent or is it happening for all agents?
      • It is happening for all agents.
  • The “iqcdwrapper.dll” is a helper dll which is loaded when a user attempts to browse from policy editor. The dll may have failed to load due to windows security updates or some other unknown reason. As a workaround for the browsing failure, you will have to enter the path manually for the policy to be applied or work as expected.

    There is a fix which is planned for CG 6.2 release.

     

     

    alkamm_0-1617298553011.png