cmdctrl DB error after upgrading from v3.0.1 to 3.2

Hello!

I just upgraded PAM Manager Server from version 3.0.1 to 3.2 and cannot get any new record from Command Control in Reports module (rules work fine). The logs shows these errors:

[INDENT]Thu Nov 30 13:04:48 2017, 600, 3476080384, 4935, Info, Db audit.ldb - SQL Statement, INSERT INTO cmdctrl.CmdCtrl ("original_cmd","native_cmd","cmd","runAs","runHost","relayServer","host","user","term_type","term_rows","term_cols","submit_tty","submit_pgrp","codeset","authorized","sessionCapture","videoCapture","secondFactor","auditgroup","AUDIT_VER","fkey",raw) VALUES (:original_cmd,:native_cmd,:cmd,:runAs,:runHost,:relayServer,:host,:user,:term_type,:term_rows,:term_cols,:submit_tty,:submit_pgrp,:codeset,:authorized,:sessionCapture,:videoCapture,:secondFactor,:auditgroup,:AUDIT_VER,:fkey,:raw);
Thu Nov 30 13:04:48 2017, 600, 3476080384, 4935, Info, Db audit.ldb - SQL Error, table cmdctrl.CmdCtrl has no column named secondFactor
Thu Nov 30 13:04:48 2017, 600, 3476080384, 4935, Error, Error recording audit data (failed to update /opt/netiq/npum/service/local/audit/log.msq.cmdctrl) 175001[SQL logic error or missing database]
Thu Nov 30 13:04:48 2017, 600, 3476080384, 4935, Error, Failed to load audit messages
[/INDENT]

Any idea how can I fix this error with the database?

Thanks so much!
Daniel S.
  • Hello Daniel, this is a good question.

    I suspect that perhaps not all of the packages have been successfully upgraded to PAM 3.2. Can you verify if all the packages show as 3.2.0.0 (From the Hosts Console > select the PAM Manager server / audit server > Packages) ?
    Particularly the audit and cmdctrl packages.
  • Hello Daniel, this is a good question.

    I suspect that perhaps not all of the packages have been successfully upgraded to PAM 3.2. Can you verify if all the packages show as 3.2.0.0 (From the Hosts Console > select the PAM Manager server / audit server > Packages) ?
    Particularly the audit and cmdctrl packages.
  • Hello Daniel, this is a good question.

    I suspect that perhaps not all of the packages have been successfully upgraded to PAM 3.2. Can you verify if all the packages show as 3.2.0.0 (From the Hosts Console > select the PAM Manager server / audit server > Packages) ?
    Particularly the audit and cmdctrl packages.