Cybersecurity
DevOps Cloud (ADM)
IT Operations Cloud
Summary
When logged into the admin console, and selecting the options Configure Services => Initialize Services for Single Server Deployment, an error is returned stating unable to open database file.
Products
Voltage SecureData
Environment
SecureData
Situation
When logged into the admin console, and selecting the options Configure Services => Initialize Services for Single Server Deployment, an error similar to the following is returned:
"/usr/lib/python2.7/site-packages/django/db/backends/base/base.py", line 130,
in ensure_connection self.connect()
File "/usr/lib/python2.7/site-packages/django/db/backends/base/base.py", line 119,
in connect self.connection = self.get_new_connection(conn_params)
File "/usr/lib/python2.7/site-packages/django/db/backends/sqlite3/base.py", line 204,
in get_new_connection conn = Database.connect(**conn_params)
OperationalError: unable to open database file
Cause
This error usually indicates a locked or corrupted SQLite 3 database file on the Management Console server.
Resolution
To correct the issue, rename the file /opt/vsmgmt/db/database.sql3 using the following command, as user root:
mv /opt/vsmgmt/db/database.sql3 /opt/vsmgmt/db/database.sql3.backup
Afterwards, run the admin console again, and select the options Configure Services => Initialize Services for Single Server Deployment. Continue configuring the SecureData server as per the installation guide.
URL Name
KM000016902