This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Need to secure Archives folder for various PVCS users, how can this be done ?

Hi,

I have installed version 8.6.3.0, this is desktop client version. I have setup a project DB and projects as per my requirement, along with the work file and archives location. The difficulty presently I am facing is that this archives folder is accessible to all users who join in to this server (using RDP) using their IDs. While I have restricted access to these individuals in the PVCS based on their IDs, I am concerned that these users also have access to the archives folder, where they can remove the files by mistake.

If I restrict the folder access to read-only to these users, then they won't be able to get, lock or check-in the files from their IDs.


It would be nice if some guidance can be given on how to safeguard this folder.

Many Thanks,

Vishnu

  • Suggested Answer

    Hello Vishnu,

    To solve this issue use the PVCS VM File Server to access your repository. Only the user ID running the PVCS Version Manager Web Application Server service needs access to the repository directory (can be any user ID; defaults to Local System). Desktop Client users connect to the File Server using specific URL.

    Please read the File Server presentation attached to the following KB doc to see why this solves your problem, and how to set it up:

    https://knowledgebase.serena.com/InfoCenter/index?page=content&id=S126695

    With kind regards,

    - Richard.

  • Hello Richard !!

    :-) VM file server, Greek and Latin to me when I read the administrator guide the first time and decided to skip it and install PVCS as desktop client. Now it makes sense. Thank you so much again !! 

    The document you had created was very handy and easy to follow. I had installed VM file server now and tried to create a PDB, however I am getting an error at time of creating them. I have attached the document for your reference. I am not sure, If I had messed up anything or there is something in PVCS that has to be fixed. 

    Can you please take a look and suggest ? DOCX

  • Hello Vishnu,

    Thanks for the feedback. I'm glad to hear the KB doc helped.

    If you see two password prompts then your PVCS VM installation might have been setup with a hardcoded Create project database password. To check, please login to the SampleDB on your desktop client (or any project database where you are a SUPERUSER), then go to Admin | Make Secure and look here:

    If the box Require password for create of project databases was inadvertently checked, please uncheck and try again.

    Note that the archives directory the Project Database R:\archives will end up in C:\DLKH\PVCS\archives\archives. Nothing wrong with that, but potentially confusing. I typically recommend naming the PDB directory similar to the Name you assign to the project database (here "ProjectDatabase"). For that to work, either the ClientName has to support that path (R:\ProjectDatabase) or the Client Name becomes a top-level directory that you create underneath.

    I strongly recommend you create a Revision path directory as well, or you cannot add files to a project database using the default configuration (see KB doc S138879).

    For new PDBs I recommend using a fake UNC path like \\vmfs or \\pvcs as your Client Name, and a Project DB path and Revision path directories like C:\FS\PDBs and C:\FS\Revs respectively.

    Then you can create the project database with name "MyPDB" and path "\\vmfs\MyPDB" which would be created in C:\FS\PDBs\MyPDB and C:\FS\Revs\MyPDB.

    If you have an existing PDB that you want to move under File Server control, your Client name has to match the path everyone already uses to access the PDB.

    Hope this helps!

    Kind regards,

    - Richard.

    P.S. The SampleDB is located in C:\ProgramData\Serena\vm\SampleDB. You can login with any user ID and no password.

  • Hi Richard,

    Thanks you for all the guidance and resolution provided. I have changed my UNC path as per your suggestion and also created the revision path and I have set up the PDB. 

    Pertaining to the password prompts, I was unable to figure out. I did check everywhere to see if I had set this inadvertently, but no I was not able to see them anywhere. As a last resort (being a IT guy) uninstalled and re-installed the VM and now it seems to work fine. 

    Have a great day and thanks again for all the help offered !!

    Regards,

    Vishnu 

  • Hi Vishnu,

    Gladly done. Reinstalling PVCS VM would reset any password requirements that someone might have embedded into your installation, so that is indeed another way to solve the problem :-)

    Happy to see it's all working now!

    Kind regards,

    - Richard.