This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Native authentication window in Chrome with Silk Performer 21.0

Hi All,

I'm trying to migrate the browser driven scripts from IE to Chrome. My Problem are the native chrome windows and dialog boxes. 

In this case I open a website and get the authentication window in Chrome. The function "BrowserSetAuthentication" works only with IE. Is there a way to handle this window in Chrome?  

I've tried to use http://<username>:<password>@example.com/testpage but this didn't work. Does anyone have an idea how to realize this?

Thanks
Bernd

Parents
  • Hi ,

    maybe its way too late for a response but i saw your posting today and checked it with one of my websites in Silk Performer (20.5 in my Case).

    I have a private website that requests username password via .htaccess file. I think its the same in your case.

    I was able to get it working. Maybe this helps other user in the future.
    I tried several things but what was finally working is:

    BrowserNavigate("http://<username>:<password>@domain.com");
    BrowserNavigate("http://domain.com");

    So first Navigate to the URL with Authentification details in URL like you mentioned in your post and then do another BrowserNavigate to the normal Website and now it was showing me the Website without any problem.

    Hope this helps someone

Reply
  • Hi ,

    maybe its way too late for a response but i saw your posting today and checked it with one of my websites in Silk Performer (20.5 in my Case).

    I have a private website that requests username password via .htaccess file. I think its the same in your case.

    I was able to get it working. Maybe this helps other user in the future.
    I tried several things but what was finally working is:

    BrowserNavigate("http://<username>:<password>@domain.com");
    BrowserNavigate("http://domain.com");

    So first Navigate to the URL with Authentification details in URL like you mentioned in your post and then do another BrowserNavigate to the normal Website and now it was showing me the Website without any problem.

    Hope this helps someone

Children
No Data