WebDriver update for Silk Agents

0 Likes

If during BDLT recording, or tryScript you get an error, from SilkWebdriver, the cause of the problem could be that you don't have the relevant webdriver for the given browser.

Automated update

Usually you can trigger an update from Silk Workbench:

  • right click on agents → "Configure Project Agents..."
  • Go to "Configure Agent Pool"
  • right click on an agent which you want to update and select "Update Webdriver"

Manual update

If for some reason the automatic update is not working, then include the required webdriver manually.

  • Download the relevant webdriver for your browser from the web
  • Go to "C:\Program Files (x86)\Silk\Silk WebDriver\ng\WebDriversSWD\Windows" Select the folder of your web browser, create a folder whit the version of the webDriver as the name, and copy the executable there.
  • Open with a text editor "C:\Program Files (x86)\Silk\Silk WebDriver\ng\WebDriversSWD\Common\Config\<Browser>\WebDriverVersionMapping.properties" and add a line with the new version
  • Do the same steps in the Silk installation folder
    • Go to "C:\Program Files (x86)\Silk\Silk Performer 21.0\BrowserDrivers\WebDrivers\Windows" Select the folder of your web browser, create a folder whit the version of the webDriver as the name, and copy the executable there.
    • Open with a text editor "C:\Program Files (x86)\Silk\Silk Performer 21.0\BrowserDrivers\WebDrivers\Common\Config\<Browser>\WebDriverVersionMapping.properties" and add a line with the new version

Example

Adding webdriver for chrome version 98.0.4758.102

The relevant webdriver was downloaded from: https://chromedriver.storage.googleapis.com/index.html?path=98.0.4758.102/

For Silk:

  • "C:\Program Files (x86)\Silk\Silk Performer 21.0\BrowserDrivers\WebDrivers\Windows\Chrome\98.0.4758.102\chromedriver.exe" was added
  • "C:\Program Files (x86)\Silk\Silk Performer 21.0\BrowserDrivers\WebDrivers\Common\Config\Chrome\WebDriverVersionMapping.properties" was updated

For SilkWebDriver:

  • "C:\Program Files (x86)\Silk\Silk WebDriver\ng\WebDriversSWD\Windows\Chrome\98.0.4758.102\chromedriver.exe" was added
  • "C:\Program Files (x86)\Silk\Silk WebDriver\ng\WebDriversSWD\Common\Config\Chrome\WebDriverVersionMapping.properties" was updated

Contents of the .properties file in both cases:

WebDriverVersionMapping.properties

89=89.0.4389.23
90=90.0.4430.24
91=91.0.4472.101
92=92.0.4515.107
93=93.0.4577.15
98=98.0.4758.102

Notes

Please note that your installation path might differ from mine, so please adjust accordingly.

If your agent is installed under Load Runner, then you should search for it in the Load Runner installation folder. For example: "C:\Program Files (x86)\Micro Focus\LoadRunner\bin\Silk"

The webdrivers are not backwars compatible, this means that if you have chrome browser 98, then you need chrome webdriver 98. Chrome webdriver 99 does not cover browser version 98!

Official Sources for browser webDrivers

https://chromedriver.chromium.org/downloads

https://github.com/mozilla/geckodriver/releases

https://developer.microsoft.com/en-us/microsoft-edge/tools/webdriver/

https://github.com/operasoftware/operachromiumdriver/releases

Comment List
Related
Recommended