This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

How to solve Silk4NET playback error for multiple scripts?

Hi,

In Silk4NET I have created many vb.net scripts and run them as a test suite (eg 20 scripts). It takes 2 hours to execute 20 scripts.

I'm facing playback issue in Silk4NET. The scripts are executed within 30 minutes, after that the execution is stopped automatically and shows the below error in Silk4NET.

We need to run all the scripts together for more than 2 hours. but, it is working less than 30 minutes

Note: Test suite execution worked in Silk Test Workbench, but issues faced only in Silk4NET.

Do I need to change any settings in Silk4NET?

High Priority Issue in our project

Can anyone reply ASAP?

Regards,

Ambika

Parents
  • Hi  

    What was the status of the test in Visual Studio?

    It looks like the test was possibly aborted but you will need to check the Visual Studio Test Explorer to determine more information.

    Regards
    Robert

  • Verified Answer

    Hi Ambika,

    If it is related to your tests timing out, try adding the "Timeout" attribute to your test methods, for example:

            [Timeout(TestTimeout.Infinite)]
            [TestMethod]
            public void TestMethod1()
            {
                    ....
                    ....
                    ....
            }

    -Robert

  • Hi Robert,

    Thanks a lot for the quick reply.

    As you suggested, I modified the "TestMethod()" method with "Timeout" and it worked.  Now I can run all the scripts together for more than 2 hours.

    Thanks once again.

    Regards,

    Ambika

Reply Children
No Data