This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

UFT Developer Runtime crashing after seconds

After installing UFT Developer (v2023.0.0585) with a Trial license, when I try to launch the UFT Developer Runtime, it launches for ~18 seconds, and then exits without any error prompt.  This happen regardless of how I launch it (Start shortcut, Command Line or through Visual Studio.

Versions:

  • Windows 10 Enterprise
  • Node.js v17.9.1
  • Visual Studio 2022 v17.5.5
  • .Net Framework v4.8.04084

leanft.runtime.log has the following:

[2023-05-09T13:38:14.404] [INFO] ChannelHelper - _cleanPendingRequests: number of pending requests is 0
[2023-05-09T13:38:14.404] [ERROR] WSCommunicationChannel - _onError: Got error while trying to connect to ws://localhost:58227 : connect ECONNREFUSED ::1:58227
[2023-05-09T13:38:14.404] [INFO] ChannelHelper - Channel close. ChannelId:0
[2023-05-09T13:38:14.404] [INFO] ChannelHelper - _cleanPendingRequests: number of pending requests is 0
[2023-05-09T13:38:14.404] [INFO] WSCommunicationChannel - _onClose : Disconnected from ws://localhost:58227
[2023-05-09T13:38:14.404] [INFO] LightWeight.Dispatcher - onDisconnect: disconnected from { target: 'LftRuntime' }
[2023-05-09T13:38:14.404] [INFO] LightWeight.Dispatcher - disconnected from NativeRuntime!
[2023-05-09T13:38:14.404] [INFO] LightWeight.Dispatcher - NativeRuntime is down!, exiting...
[2023-05-09T13:38:14.404] [INFO] LicenseManager - onBeforeClose: releasing license
[2023-05-09T13:38:14.404] [INFO] SessionManager - onClientDisconnected: eventInfo: { client: { target: 'LftRuntime' }, additionalInfo: {} }
[2023-05-09T13:38:14.404] [INFO] ContextProvider - onClientDisconnected : Going to remove the following environments []
[2023-05-09T13:38:14.405] [WARN] ChannelHelper - Error reported from channel 0 : Error: connect ECONNREFUSED ::1:58227
at TCPConnectWrap.afterConnect [as oncomplete] (node:net:1195:16) {
errno: -4078,
code: 'ECONNREFUSED',
syscall: 'connect',
address: '::1',
port: 58227
}

The Port that causes the ECONNREFUSED changes every time that I try to Start the Runtime.

If I open the Service in a browser during the brief window when the Runtime shows as running, this is what it shows:

I have attached all of the Logs here:

Logs.zip

  • Seeing the same error for us too using Eclipse 2022-09

  • Hello,

    This is a problem we've been encountering lately on certain Windows machines (happens more often on Windows Server) and is related to a module that acts as a server and starts a connection on an IPv4 adress and UFTd runtime engine trying to connect to it using an IPv6 address.We already have hot fix, in order to get it please contact our support team.

    Thanks!!

  • Hi Alin,

    Thanks for the response.  This hotfix has solved the issue with the Runtime crashing, however, the Object Identification Center still gives an error that that the Runtime is not up:

    I don't know if this is related, but I am having an issue with the Trial license for the Runtime.  It is telling me I have no valid license, rather than giving me a Trial period as per the Information on the Activation email.  I did install the software originally on the 12th April, but I should still be within the Trial period.

    Thanks

    Neil

  • Hi,

    Glad to see that the runtime engine issue was solved. Regarding the license, have you installed UFTd with the trial license on this specific machine in the past? The trial license days are counted per machine, so if you install UFTd trial now and keeps it for 10 days then install it again in a year or so, you will only have 20 days left then or whatever was remaining from the initial install, it's being added up. I would suggest to try installing UFTd on a clean machine where it wasn't installed before and see if you're getting the same issue.

    Thanks,
    Alin

  • This looks to be working for me as well. I dont have other error Neil is seeing, but we do have a full license installed.

    Last question, do you know if these hot fix files will be added as a patch or will they need to be added manually each time?

    thx

  • Hi Alin,

    This is the first time I have installed UFTd on this machine.  I have previously have UFT One installed, would this cause any issues with the Trial period?  Assessing the product on a Clean Machine is not very easy for me.

    Thanks

    Neil

  • Unfortunately, for UFTd 2023, the hot fix will have to be applied manually. However, we'll include it in the next release.

    Thanks,

    Alin

  • Most likely UFT One consumed the trial license when was installed previously. As far as I know, the two products use the same license file so if the trial is consumed with UFT One, it won't be available for UFTd later. So there are only two options available here, either install on a clean machine or switch to a full license.

    Thanks,

    Alin

  •    

    We've done a more generic fix that should solve this issue for all environments. Can you please try this one too and see if it fixes the problem as well?

    Can you please contact our support team in order to get it? That's the official way to hand out hot fixes.

    Thanks,
    Alin

  •  I have contacted Support, and then been told I need to contact the Trial team to get the hotfix.  I will check this once I get an answer from them