UFT Developer Runtime engine not getting started on Jenkins Slave machine

I am running my test on Jenkins slave machine which is connected via Jenkins agent as service.

UFT developer runtime engine is not getting enabled on the slave machine when I trigger build from Jenkins server but when I run directly in Jenkins slave the runtime engine gets started.

I even tried executing leanft.bat file to get engine started via putting it as part of Execute Batch command in Jenkins but sill its not getting started in slave whereas if I directly run the bat file in slave it works fine.

Is there something wrong I am doing.

  • Suggested Answer

    when you are running UFT Developer from CICD like Jenkins you should ensure that the Jenkins agent has the right user and privileges.

    By default, the Jenkins agent runs under SYSTEM user and session 0 this session is not an interactive session which our engine needs in order to perform the GUI operations.

    Please try to give to the Jenkins service an interactive user/domain user.

    By doing this you should be able to start the engine from Jenkins.

    Corneliu,