Strange, Vague Errors on Document Access and Create - 23.4 with Patch

Hello All.. we're experiencing one similar error (message) with two different clients in two different scenarios.

Client 1 - After upgrade and patched, a user was having issues editing/viewing documents that were in a in a restricted classification.  They are an administrator and when trying to access these documents, this error appears: Error extracting Record <Number>.  Content Manager reported an error.  This operation is not permitted"

Windows Event log on server says the same thing as the error message.

Client 2 - After upgrade client is trying to create electronic records via the web client.  Originally suspected it was an issue with Outlook, but even local files were erroring out.  Dragging and Dropping to the webclient and then selecting appropriate record type, it looked like everything was working, then this error popped up:  "Content Manager Workgroup server on <name> reported an error.  This operation is not permitted."

However, in this case, when we promoted the Knowledge worker to an administrator, it worked without issue.

Has anyone experienced these vague errors and able to provide some context? Upgraded or not? Patched or not?

  • We're having similar "operation is not permitted" error on workflows with the last activity on an automatically approving dummy location. The end-user on the activity just before that cannot approve without getting that error on their activity unless we uncheck the automatic completion for the dummy location.

    Support was able to replicate it only using the latest security patches for for 10.0 and 23.4 (case 02865156).

  • I've encountered this on a customer site, specifically to do with record creation, on this build. It was independent of the client patch version (23.4.0 or 23.4.1)

    It turned out that the owner and home locations were not valid in some way - there was something in their profile that was not as it seemed. The fix was to set the locations to another user type and then back again (the standard "reset to system option profile" trick), and then record creation worked normally.

  • I came across another variation today - the system option for generating thumbnail renditions was ticked, and the record update (check in) failed, as the clients wants to delete the old thumbnail rendition, and rendition deletion is not permitted for this user type.

  • This is great information Alex.  I'll try some of these changes and confirm the thumbnail suggestion in your other post and report back.

  • I have a new error today.. with a user trying to drag and drop from the desktop.  Their progile is an OOTB Knowledge Worker.

  • OK.. so this was an error caused by the client "ADDING" Unique Identifier to the BLOCKED search methods.  It was erroring out when the Web Client was trying to re-display the page with the newly created record on display.  I would consider this not related.

  • Hello, 

    I've been working with OpenText support for a customer that is experiencing this issue.  The "Operation is not permitted" error would occur when the user attempted to view a document. The customer was able to replicate the issue several times. It should be noted the customer was using Content Manager Desktop, not that I think that has anything to do with the issue. 

    We were all on a support call yesterday and found that this has been identified as a known issue and a fix has been incorporated into newer builds of Content Manager. 
    The support person shared the versions that address this issue. Unfortunately, the release we want (23.4.2) is not available yet. 

    Fixed in versions: 24.2

                                 10.1 Patch 5 Hotfix 2

                                 10.0 Patch 6 Hotfix 1

    Pending Release in versions:

                                  10.1 Patch 6

                                   23.3.2

                                   23.4.2

    A KM has been published. However, it does not include all the corrective versions.

    https://portal.microfocus.com/s/article/KM000028659?language=en_US

    Hope this helps. 

                                   

        

  • A quick update on this issue. Below is an excerpt from a support email. 

    "In order to help you to solve the issue as soon as we can, we are planning to include this issue into our next HF i.e. CM 23.4 P1 HF2

    This is the reference ID - Issue 922072 - ACL - This operation is not permitted error when trying to view a record a user should have access to. You can suggest customer to apply this HF to get the fix.

    ETA for CM 23.4 P1 HF2 is by end of next week."

    So, that would be June 7th 2024.  Lucky number 7! Slight smile

  • Hi Sander,
    We've currently testing 10.1 Patch 5 Hotfix 2 (the security vulnerability fix) and are having the same issue.  The prior activity will look as though it has completed despite the error message, but after a few seconds, the prior activity will return to a 'ready to start' state.

    The workgroup server log has "Server-side validation failed for the permission Complete actions or activities", even though this is clearly enabled for the dummy location.  Have you had any resolution to your case?

  • It's supposed to be fixed in 23.4 patch 1 hotfix 2 which, according to another forum post, should be released end of this week.

    Don't know if there will be a hotfix for other releases.