HP Storageworks 1/8 G2 Autoloader frozen

We have an HP Storageworks 1/8 G2 Autoloader Tape drive that the Firmware seems to be frozen on it.  The front control panel is locked, the web based GUI will not come up, and can't access from the OS. The last time this happened I had to pull the power plug, waited about 20 seconds, plugged back in and when it finished the boot up, I was able to access from the front control panel and the web based GUI.  However the only way the HP-UX 11.31 server would re-recognize it was to reboot the server itself also.  I've also tried unplugging and re-plugging in the cable in the back in case it's a connection issue.  There are no fault lights or other indications on the drive and HP has ran diagnostics from the server itself with no indicators.

 

My question is, does anyone know what might be causing it to freeze?

 

On the server side with OMNISV down, I'm still seeing this, which I think might be preventing the server from recognizing the tape drive after its turned back on:

 

# ps -ef | grep omni | grep -v grep
    root  2257  2256  0  Oct 12  ?         0:00 /opt/omni/lbin/bma -name drive1 -policy 10 -type 13 -library tape_library -seg 2000 -dev /dev/rmt/4mn 1 -blk 256 -dev_serial HU
    root  2256  1128  0  Oct 12  ?         0:00 /opt/omni/lbin/bma -name drive1 -policy 10 -type 13 -library tape_library -seg 2000 -dev /dev/rmt/4mn 1 -blk 256 -dev_serial HU

 

and if I do a ptree I am getting this:

 

# ptree -s 2256
1          init
 1128       /usr/sbin/inetd
  2256       /opt/omni/lbin/bma -name drive1 -policy 10 -type 13 -library ta
   2257       /opt/omni/lbin/bma -name drive1 -policy 10 -type 13 -library ta
   2258       uma -pol 10 -dev /dev/rmt/4mn 1 -type 13 -ioctl /dev/rchgr/auto

 

My concern is if its ok to kill 2256 since its a child of inetd with users on the system?  Additionally, should I kill 2257/2258 first or just 2256? 

 

Thanks ahead of time for any assistance I can get.

 

P.S. This thread has been moved from Tape Backup (Small and Medium Business) to Data Protector Support and News Forum. -HP Forum Moderator

Parents
  • Have you checked to see if the library firmware is up to date?  It has been a long time but there was a problem in early firmware builds where some network traffic, usually a security scanner probe, could trigger a routine that had a memory leak and eventually after enough probes the library controller would halt.

     

    I haven't heard of any reason that a recent firmware build would have a similar problem but if there were another similar problem the network connection would be my first guess.

  • The Autoloader firmware was on "2.50 /  2.00 n" earlier today, however I upgraded the firmware to current "4.30 /2.50 n" about 2 hours ago.  The Drive Firmware Revision is/was S63W which is current (2007 last update).

     

    Cutis, about the same time you gave your reply I was in the process of downloading and loading the firmware.  Thanks for the reply though.

  • I tried killing the processes late last night with no luck so I rebooted the server and of course it found the tape drive again.  Seems like there should be a better way to do this than to have to reboot everytime the tape drive has a hiccup.  I'm going to leave this open and wait for 2 weeks to see if it does it again. Last time it only stayed up for 10 days.     

  • Fred, I have had similar issues and found that the server needed some patches. I cannot remember any particulars. Run an assessment or search for any driver patches for your system.

    Tommy

Reply Children
No Data