The specified user group 'admin' does not exist. When trying to add new user to a fresh installation

The is a fresh installation of Data Protector 10.40 on RHEL 7 (fully updated). When trying to add a user with any of the predefined DP groups (admin, user, or operator), I get the message: The specified user group 'admin' does not exist.

Here I demonstrate the problem using the example copy/pasted from the CLI reference guide:

[root@adearc01 ~]# /opt/omni/bin/omnicc -ver
Micro Focus Data Protector A.10.40: OMNICC, internal build 118, built on Tue 21 May 2019 09:50:46 BST
[root@adearc01 ~]# cat /etc/opt/omni/server/users/ClassSpec
CLASS admin
PERMISSION -1
DESCRIPTION "Administrator Class"

CLASS operator
PERMISSION 550911
DESCRIPTION "Operator"

CLASS user
PERMISSION 32
DESCRIPTION "Simple User Class"

[root@adearc01 ~]# for group in admin operator user ; do
> omniusers -add -type U -name root -usergroup $group -group \* -client client.company.com
> done

The specified user group 'admin' does not exist.

The specified user group 'operator' does not exist.

The specified user group 'user' does not exist.

I have tried reinstalling the whole of DP, but that has made no difference.

Tags:

  • Verified Answer

    Hello , 

    This error means that users and groups have not been migrated to Keycloak: 

    The specified user group 'admin' does not exist.

    I am sure that if you run omniusers -list you will receive nothing, just skip the line. 

    So you need to run the migration manually:

    /opt/omni/bin/perl /opt/omni/sbin/userMigrate.pl


    After that, you will be able to run the omniusers -add command. 

    Best regards, 

    Victor Andrés Fallas Salazar
    DP L3 Technical Support Engineer
    San José, Costa Rica

    Please consider to give a like, and if it solved your issue, consider to mark it as the solution. 

  • Running the user migration fixed the problem exactly as you described. Thank you very much.
  • I am really glad to know that this worked.
    Hope you have a great day ahead.

    Victor Andrés Fallas Salazar
    DP L3 Technical Support Engineer
    San José, Costa Rica

    Please consider to give a like, and if it solved your issue, consider to mark it as the solution. 

  • Hi Victor, I have a same problem but manually migration is not working. 

    # /opt/omni/bin/./perl /opt/omni/sbin/./userMigrate.pl
    Log file: /var/opt/omni/server/log/dp_user_migrate_3.log

    User 'root|*|deblndw012x.ad001.siemens.net' could not be migrated

    User 'hpdp|*|deblndw012x.ad001.siemens.net' could not be migrated

    User 'Z0044D8A|AD001|*' could not be migrated

    # omniusers -add -type W -name z0044d8a -usergroup admin -group ad001.siemens.com -client dsv9064c

    The specified user group 'admin' does not exist.

    Could you help please? DP support is not able to help me yet.

  • Hi, 

    I am also facing the same issue. How your issue gets resolved. Can you please help

  • Hello, my problem was fixed by revision of local users and perrmission. Oracle and hpdp user must be localy in /etc/passwd. Groups as well. We are using NIS and oracle user was only in NIS, not localy. So do revision of users and permission properly.