DP9.07 Upgrade Red Hat from 7.2 to 7.9 - yum Transaction check error:

Hello everyone,

I want to update my CellServer Version A.09.07 from Red Hat 7.2 to Version 7.9 and I get some yum Error's :

yum update.....

Transaction check error: -(I get it for createrepo.... and filesystem)

/etc from install of createrepo-0.9.9-28.el7.noarch conflicts with file from package CORE_Patch-A.09.00-10.x86_64
file /etc from install of createrepo-0.9.9-28.el7.noarch conflicts with file from package DA_Patch-A.09.00-9.x86_64
file /etc from install of createrepo-0.9.9-28.el7.noarch conflicts with file from package MA_Patch-A.09.00-8.x86_64
file /etc from install of createrepo-0.9.9-28.el7.noarch conflicts with file from package CC_Patch-A.09.00-8.x86_64
file /etc from install of createrepo-0.9.9-28.el7.noarch conflicts with file from package DOCS_Patch-A.09.00-8.x86_64
file /etc from install of createrepo-0.9.9-28.el7.noarch conflicts with file from package AUTODR_Patch-A.09.00-7.x86_64
file /etc from install of createrepo-0.9.9-28.el7.noarch conflicts with file from package VEPA_Patch-A.09.00-8.x86_64
file /etc from install of createrepo-0.9.9-28.el7.noarch conflicts with file from package VMWGRE_Patch-A.09.00-6.x86_64
file /etc from install of createrepo-0.9.9-28.el7.noarch conflicts with file from package NETAPP_Patch-A.09.00-7.x86_64
file /etc from install of createrepo-0.9.9-28.el7.noarch conflicts with file from package SMISA_Patch-A.09.00-8.x86_64
file /etc from install of createrepo-0.9.9-28.el7.noarch conflicts with file from package DB2_Patch-A.09.00-6.x86_64
file /etc from install of createrepo-0.9.9-28.el7.noarch conflicts with file from package EMC_Patch-A.09.00-6.x86_64
file /etc from install of createrepo-0.9.9-28.el7.noarch conflicts with file from package SAPHANA_Patch-A.09.00-6.x86_64
file /etc from install of createrepo-0.9.9-28.el7.noarch conflicts with file from package SODA_Patch-A.09.00-6.x86_64
file /etc from install of createrepo-0.9.9-28.el7.noarch conflicts with file from package SSEA_Patch-A.09.00-6.x86_64
file /etc from install of createrepo-0.9.9-28.el7.noarch conflicts with file from package EMCVNX_Patch-A.09.00-4.x86_64
file /etc from install of createrepo-0.9.9-28.el7.noarch conflicts with file from package EMCVMAX_Patch-A.09.00-4.x86_64
file /etc from install of createrepo-0.9.9-28.el7.noarch conflicts with file from package MYSQL_Patch-A.09.00-4.x86_64
file /etc from install of createrepo-0.9.9-28.el7.noarch conflicts with file from package SYBASE_Patch-A.09.00-4.x86_64
file /etc from install of createrepo-0.9.9-28.el7.noarch conflicts with file from package SAPDB_Patch-A.09.00-4.x86_64
file /etc from install of createrepo-0.9.9-28.el7.noarch conflicts with file from package ORACLE8_Patch-A.09.00-3.x86_64
file /etc from install of createrepo-0.9.9-28.el7.noarch conflicts with file from package LOTUS_Patch-A.09.00-3.x86_64
file /etc from install of createrepo-0.9.9-28.el7.noarch conflicts with file from package POSTGRESQL_Patch-A.09.00-1.x86_64

 

 

Any Idea to solve this yum Error?

 

Greetings

  • Verified Answer

    Hello ,

    This is a legacy problem I had a few times back in the days of DP 9.x. This is caused by the 9.07 patches or the way they have been installed. Usually it is done using rpm -Uvh --replacefiles --replacepkgs.

    You could either try to remove or upgrade the createrepo package with --replacefiles --replacepkgs and then run the other upgrades.

    Regards,
    Sebastian Koehler