Windows File Type Exclude

I'm wanting to exclude SQL database files from a Windows server backup.  I created a Filesystem template and under Filter [Trees] Advanced, I selected the Windows tab, and under "Excludes", I added *.ndf, *.mdf, and *.ldf.  I then selected my Filesystem Specification that contains my SQL server and applied the template.  All of the database files are still getting backed up.  What am I doing wrong?  I'm a newbie, be gentle.

Thanks,
Randy

Parents
  • Hi Randy

    This is a known issue that will be solved in future versions

    https://softwaresupport.hp.com/group/softwaresupport/search-result/-/facetsearch/document/LID/QCCR2A50171?lang=es&cc=es&hpappid=202392_OSP_PRO_HPE

    The workaround is not to use the template but change the datalist itself filter what the template should have done.

    Best Regards

  • Below is what I assume is the datalist for this client.  JBasilio, are you saying that I need to unselect each file individually?  Like expend E:\MSSQL\Data and uncheck each mdf, ndf and ldf file individually?

     

    DATALIST "CLSESTMDBDEV"

    DYNAMIC 1 5

    DEFAULTS

    {

    FILESYSTEM

    {

    -vss no_fallback

    } -protect days 8

    RAWDISK

    {

    }

    }

    DEVICE "VTL1-Drive-001"

    {

    }

    DEVICE "VTL1-Drive-002"

    {

    }

    DEVICE "VTL1-Drive-003"

    {

    }

    DEVICE "VTL1-Drive-004"

    {

    }

    DEVICE "VTL1-Drive-005"

    {

    }

    DEVICE "VTL1-Drive-023"

    {

    }

    DEVICE "VTL1-Drive-024"

    {

    }

    DEVICE "VTL1-Drive-025"

    {

    }

    DEVICE "VTL1-Drive-026"

    {

    }

    DEVICE "VTL1-Drive-027"

    {

    }

    DEVICE "VTL1-Drive-049"

    {

    }

    DEVICE "VTL1-Drive-050"

    {

    }

    DEVICE "VTL1-Drive-051"

    {

    }

    DEVICE "VTL1-Drive-052"

    {

    }

    DEVICE "VTL1-Drive-053"

    {

    }

    DEVICE "VTL1-Drive-065"

    {

    }

    DEVICE "VTL1-Drive-066"

    {

    }

    DEVICE "VTL1-Drive-067"

    {

    }

    DEVICE "VTL1-Drive-068"

    {

    }

    DEVICE "VTL1-Drive-069"

    {

    }

    DEVICE "VTL1-Drive-085"

    {

    }

    DEVICE "VTL1-Drive-086"

    {

    }

    DEVICE "VTL1-Drive-087"

    {

    }

    DEVICE "VTL1-Drive-088"

    {

    }

    DEVICE "VTL1-Drive-089"

    {

    }

    DEVICE "VTL1-Drive-107"

    {

    }

    DEVICE "VTL1-Drive-108"

    {

    }

    DEVICE "VTL1-Drive-109"

    {

    }

    DEVICE "VTL1-Drive-110"

    {

    }

    DEVICE "VTL1-Drive-111"

    {

    }

    DEVICE "VTL1-Drive-129"

    {

    }

    DEVICE "VTL1-Drive-130"

    {

    }

    DEVICE "VTL1-Drive-131"

    {

    }

    DEVICE "VTL1-Drive-132"

    {

    }

    DEVICE "VTL1-Drive-133"

    {

    }

    DEVICE "VTL1-Drive-138"

    {

    }

    DEVICE "VTL1-Drive-139"

    {

    }

    DEVICE "VTL1-Drive-140"

    {

    }

    DEVICE "VTL1-Drive-141"

    {

    }

    DEVICE "VTL1-Drive-142"

    {

    }

    DEVICE "VTL1-Drive-147"

    {

    }

    DEVICE "VTL1-Drive-148"

    {

    }

    DEVICE "VTL1-Drive-149"

    {

    }

    DEVICE "VTL1-Drive-150"

    {

    }

    DEVICE "VTL1-Drive-151"

    {

    }

    DEVICE "VTL1-Drive-158"

    {

    }

    DEVICE "VTL1-Drive-159"

    {

    }

    DEVICE "VTL1-Drive-160"

    {

    }

    DEVICE "VTL1-Drive-161"

    {

    }

    DEVICE "VTL1-Drive-162"

    {

    }

    HOST "clsestmdbdev.eprod.com" clsestmdbdev.eprod.com

    {

    }

     

  • Verified Answer

    Hi

    You must exclude files from each backup specification instead use a template. From backup specification go to properties-backup object summary-properties button-treess/filter tab-excludes

    Best Regards

  • Can I exclude file types, like *.mdf, or just entire drives and folders?

  • I think I answered my own question.  The "Add" button stays grayed out unless I type in something like C:\.  It won't let me start with *.  It won't give the "Add" option until it sees the "\".  This bites.

Reply Children
No Data