(DP) Support Tip: omnib command remains after BSM finished

[Error Situation]
Backup sessions are managed by executing omnib command from other schedule application .
Even though backup session completed successfully , omnib command remains .
This issue doesn't occur for all backup sessions , but it seems to occur for large backups that take more than one hour .


[Cause]
omnib command seems to be under a situation that can not receive any communication from BSM .
After starting backup sessions by omnib command , omnib command will receive a progress of backup session from BSM .
If backup objects are very large , omnib command will wait for a long time without any communication between BSM .
If FireWall exists and closes a port that omnib command uses because the port is in idle condition
omnib command can not receive the end of backup session from BSM to close itself .
As the result , omnib command will remain even though backup sessions finished .


[Workaround / Fix]
Keepalive settings will need to be considered .
By sending the keepalive packet that contains null data , it helps to prevent the link from being broken .
DataProtector can use Keepalive by setting OB2IPCKEEPALIVE=1 in .omnirc file .
Regarding intervals , manuals or guideline for each Operating System needs to be referred .

ex.)
- HP-UX
 To confirm the current value :
    ndd -get /dev/tcp  tcp_keepalive_interval
 To set new value :
    ndd -set /dev/tcp  tcp_keepalive_interval  900000

- Linux
 To confirm the current value :
    sysctl net.ipv4.tcp_keepalive_time net.ipv4.tcp_keepalive_intvl net.ipv4.tcp_keepalive_probes
 To set new value :
    echo 600 > /proc/sys/net/ipv4/tcp_keepalive_time
    echo 60 > /proc/sys/net/ipv4/tcp_keepalive_intvl
    echo 20 > /proc/sys/net/ipv4/tcp_keepalive_probes
 Also /etc/sysctl.conf file needs to be modified to keep values after system reboot .