(DP) Support Tip: "[154:64450] User Authentication failed" with short hostname

Error Message

After upgrading from DP10.02 to DP10.03 , DP GUI can not connect to Cell Manager by indicating "[154:64450] User Authentication failed" .

Cause

It is strongly recommended that hostname is specified in fully qualified domain name (FQDN) format .
When short hostname(means hostname without domain name) is used with DP , sometimes unexpected issue might occur .

Workaround / Fix

In this case , regenerating certificates by specifying the short hostname will solve the issue .

Steps :
1. Copy the KeystorePassword from webservice.properties configuration file. The configuration file is available at the following locations:
Windows: C:\ProgramData\OmniBack\Config\client\components\webservice.properties
UNIX: /etc/opt/omni/client/components/webservice.properties

2. Run the following command:

Windows:
perl "C:\Program Files\OmniBack\bin\omnigencert.pl" -server_id <short hostname> -server_san dns:<short hostname> ,dns:<FQDN(if available)> -user_id "DOMAIN\Administrator" -store_password <keystore_password>

UNIX:
perl "/opt/omni/sbin/omnigencert.pl" -server_id <short hostname> -server_san dns:<short hostname> ,dns:<FQDN(if available)> -user_id "hpdp" -store_password <keystore_password>


3. Stop Data Protector services.
4. Start Data Protector services.