sharepoint restore question

Hello,

I've a small inquiry. In my lab I've setup a SharePoint Server to test the backup and restore options offered from DP.

DP is 9.09, SharePoint is 2014, Windows is 2016 on CM and 2012 on SharePoint. SharePoint Server is also running MS SQL Server

While I can restore without any issue with overwriting the working web app.

However I can't manage to have a restore on the same farm as another web application (to test the restore for exemple).

I always get this error :

[Major] From: OB2BAR_SHAREPOINT@sps2013.lab.lan "" Time: 4/19/2017 8:47:17 AM
[171:131]     Linking content database 'Intranet_old' to 'Web application: Intranet' failed. Error: mscorlib:Exception has been thrown by the target of an invocation.
    Microsoft.SharePoint:The attach operation cannot continue because another object in this farm already contains the same ID. Each object in a farm must have a unique ID. In order to proceed with the attach operation you must assign a new ID to this database. To attach this database with a new ID, use the Mount-SPContentDatabase command with the -AssignNewDatabaseId parameter. Note that if this new database and an existing database contain the same site collections, attaching this database will likely result in orphaned site collections due to conflicts between the two databases.

[Major] From: OB2BAR_SHAREPOINT@sps2013.lab.lan "" Time: 4/19/2017 8:47:17 AM
    Components that failed to be restored or restore was only partially successful are:
     - Web application: Intranet

 

The suggested actions are :

*If original content database is still in the farm, remove it manually from SharePoint farm or use "Unlink original content database" option.
*If object with same GUID is not an content database try to identify the conflicting object and assign it a new GUID.

 

So I did a test with ticking "Unlink original content database", then the restore is OK, the new web application is working but the original one doesn't work anymore.

So the question is : is it possible to restore (without SharePoint GRE) as a new web application and have the original web application running in parrallel. If the answer is yes, what I'm missing.

Parents
  • It should work. Run restore with the "Unlink original content database" option, then run iisreset on the farm and check availability of the original and the copied webapp.

    Edit: As JBasilio noticed, your environment combination (SharePoint 2013 on Windows 2016) does not appear to be certified with Data Protector 9.09. So "it should work" should be understood as "it should work on a certified combination", e.g. SharePoint 2013 on Windows 2012.

  • Hello

    I have some doubts about your enviroment you wrote "DP is 9.09, SharePoint is 2014, Windows is 2016"

    SPS 2014 is not a valid version I believe you meant:

    SharePoint 2013\SQL 2014\Windwos 2016...In such case this is still NOT supported and we can not guarantee sucesfull restore.

    Best Regards

  • Hello, thank you for the update.

    I'll test the IISreset.

    Yes you're right there was a typo issue. That was SPS 2013 with SQL 2014. I'm rebuilding a SharePoint 2013 box with SQL 2012 to test again.

    I'll let you know.

  • Hello,

    So now I've rebuild the SharePoint environnement :

    Windows 2012 R2 SQL Server 2012 SharePoint 2013 (All in a single box)

    Now for DP environnment : Windows 2016 DP 9.09

    I still have the issue. I can restore "on top" of the web application but If I restore aside I can't have the original application working.

    I'll log a case ASAP and keep the audience updated :)

Reply
  • Hello,

    So now I've rebuild the SharePoint environnement :

    Windows 2012 R2 SQL Server 2012 SharePoint 2013 (All in a single box)

    Now for DP environnment : Windows 2016 DP 9.09

    I still have the issue. I can restore "on top" of the web application but If I restore aside I can't have the original application working.

    I'll log a case ASAP and keep the audience updated :)

Children