Upgrade from DP 9.09 to 10.30 and VMware integration

Hi,

We've recently started to upgrade from 9.09 to 10.30 - we have a Linux Cell manager and a Virtual Center appliance running ESX 5.5. In this environment we use VMware integration, and at the end of the Cell manager upgrade it threw up a message saying that the VMware GRE plugin couldn't be unregistered. We were told we'd need to run 'omnicc -upgrade_greplugin' after all mount proxies were upgraded. We upgraded the mount proxy (Windows VM) and ran the command but got the error: ' unregister of advanced GRE web plug-in from vcenter unsuccessful. License checker internal error'. We saw license mentioned in the error so applied our license - although didn't think this would really help (and it didn't!). We've tried deleting the Virtual centre client and re-adding and all of the messages suggest this has worked - we get successfully unregistered/registered messages. However when we look in the VSphere web client we can't see the GRE management tabs. Within the virtual center GUI we can see the 'vmware granular recovery extension web client plug-in' showing as an installed plug-in but it still shows as 9.09. We thought that this might need manually removing and found notes that say to log into the vmware MOB GUI (https://VCserver/mob), but here we are not seeing any data protector extensions installed.

Another strange thing is that if we try and import the Virtual Centre server and get the username and password wrong on purpose, we still get the possitive messages about registering the GRE, and the server is added to the client list! It's almost as if it's not really trying to talk to the VC server ... just pretending to. On the other hand if we try and import a made up server name (but with the correct domain details) it throws up an error stright away.

This came about because during backup testing of VM's we have started seeing the message 'virtual centre: download of disk descriptor file failed'. Our huch was that by ensuring the GRE extension was at the correct version, this error may go away.

Any help apprectiated!

Thanks,

Andy.