GRE plugin integration with vCenter 5.5 and DataProtector 9.06

Hello all,

I'm facing some errors regarding this topic... I planned to migrate my infrastructure from vCenter / vSphere 5.1 to 5.5.

I'm licensed with the VMware GRE plugin, It works well with the 5.1 infrastructure

I already prepared the 5.5 servers, I integrated the server to DataProtector in order to validate that the GRE is working, but the problem is the following :

When I use the vSphere Web Client, if I go to the "HP DataProtector" tab, I have this error : Http Error - 500 
{"message":"Unexpected error :There was a problem while sending query to service https://myservername.mydomain:7116/dp-gui/grePlugin/GetMountProxies.jsp?newMachineTypeParam=ESX. Check that this agent is accessible."}

The server is reachable, it works properly... When I try to access the URL directly from my browser, I have a 404 error....

Maybe there is a little trick... I don't know, please help me =(

  • check your IE version. IE might need upgrading....

  • I have the same problem using IE11 or Google Chrome

    I see that the tab is named "HP Data Protector"... On the 9.06 version, it's "HPE Data Protector" if I'm right, no ?

  • Have you checked the GRE integration guide shipped with Data Protector A.09.06 in the Docs folder? If this is a VCSA you need to open the firewall on the client that has the GRE agent and on the VCSA.

    Regards,
    Sebastian Koehler

  • With VC5.5U2 and above,  GRE UI is changed from Flex to Angular and it has gone Agentless. 

    So probably you need to:

    - Delete (with remove components) the VCenter client from DP Cell manager

    - Restart VCenter service and Vcenter webclient service in VCenter server.

    - Install VMWare Granular Recovery Extension agent component in Cell manager or any other Host part of the cell. This will act as the mount proxy. (Mandatory pre-req)

    - Import the VCenter again to the cell along with select "Advanced GRE Web Plugin" tick box 

    - Close, clear the cache  and open the Web Browser; Open VCenter Web client.

    - In VM-> Manage -> HPE DataProtector -> Settings : Set the mount proxy path

    Now you can proceed to Recovery.

    Hope you are using VC5.5U2 or higher and firewall is disabled or configured for the ports in use.

  •  

    Hello nigil,

    Thank you for your help, it works, the plugin is now named "HPE Data Protector"

    Now I'm facing a different problem... The plugin is stuck with "Loading..." whan I click on the tab, so I'm unable to do the settings...

    I don't use the VCSA, I installed vCenter 5.5U3 on Windows 2012 R2 VMs, my firewall are disabled

    I'm using a Palo Alto firewall solution, I checked the communication between vCenter and Cell Manager (which act also as Mount Proxy) and between the Cell Manager and the vCenter, nothing is blocked or dropped

  • When you click on the HPE-DP tab, an auto pop-up will come,  which display the Cell Manager name. and quickly goes off.  Hope you found this. 

    Then if the screen is in loading can bedue to several issues:

    - Check HP OpenView is not installed in the same VCenter machine. (or any other HP software installed, that use the same port?)

    - Not able to communicate between CellManager-MountProxy-Vcenter.  [Add all the host resolution information to /etc/hosts file or C:\Windows\System32\drivers\etc\hosts] 

    ---------------------------------------------------------------------- 

    Still not working? 

    - Close browser and clean cache.

    - Remove the Advanced GRE Web Plugin.

    - Go to VCenter/mob ->Extension Manger (https://<VC-host>/mob/?moid=ExtensionManager) and check old HP Web Plugin is removed.

    - Restart the VCenter and WebPlugin services.

    - Add the Advanced GRE Web Plugin again , by select Apply the tick box.

    -  Open browser and check now. 

    ------------------------------------------------------------------------- 

    Also check in the integration guide for the error messages and trouble shooting.

  • Please make sure the following TCP ports are open between the vCenter server and server where the VMware GRE agent is installed. Make sure the VMware GRE agent is not installed on multiple servers. This will make troubleshooting complicated. Check the debug.log on the server where the VMware GRE agent is installed.

    5555 — the default port for Data Protector communication
    7116 — the Application Server (HTTPS AS) port
    The port ranges for the Advanced GRE Web-plugin are between 15000 and 15999.

    Regards,
    Sebastian Koehler

  • I see communication from vCenter to Cell Manager on ports 7116 and 5555, no packets dropped, it's perfect.

    When I restart vCenter Virtual Machine, I'm able to access to the "HPE Data Protector" tab, I can see the requests without the "Loading" popup, but when I try to access the "GRE Settings" page, it's stuck on "Loading"

  • GRE agent is installed on 2 servers on my infrastructure, but the vCenter choose to work with the good one

    On the "debug.log" file, I see these lines which concerns the "vmwaregre-agent.exe" process

    2016-07-07 10:35:00.638  vmwaregre-agent.exe.7960.4368 ["/lib/ipc/ipc.c $Rev: 52399 $ $Date:: 2016-03-11 08:21:03 ":1301] A.09.00 b107
    ipc_sendDataEx: IpcHandle -1 does not exist
    cmd:vmwaregre-agent.exe
    Function trace (currentLevel=3):
    	Level  3: IpcGetEntry()
    	Level  2: ipc_sendDataEx()
    	Level  1: ipc_sendDataEx(handle=-1, buffer size=0, timeout=0)
    	Level  0: OB2Utility::Run()
  • And finally, on my firewall, I have 2 rules

    vCenter any => DP CM any / action : accept

    DP CM any => vCenter any / action : accept