Data Protector with granular recovery extension on vCenter 5.1

Dear All,


I am starting to integrate the DP GRE with vCenter 5.1. 


I am using the evaluation license on vCenter 5.1 at t his moment, can I use install GRE web plug-in compoent in this vCenter?


Why I ask this because I got the error message as below


 There was a problem during VMware Granular Recovery Extension Web Plug-In installation. Check if the target system has VMware vCenter Server installed and configured


Would you mind to share your valuable experience if have this error occur before?



  • Hi All


    I have the same problem as described here.


    Followed the installation as statet in the doc and here


    - Added vCenter Server as "Disk Agent" Client

    - Added vCenter Server as VMware vCenter

    - Try to install GRE Extension > i receive the same error


    I tried to install the extension with cli on the CM Server and on the vCenter server. Allways the same error.


    Additional the second (or third) time i tried to install the extension, I receive following error

    "{30692C3E-7A60-4BD4-B021-213055B1810F}: related product unexpectedly absent from the system."


    Unfortunately there is not much information in the web about these problems.


    If I try to install the GRE Extension on the vCenter by running setup.exe (from the x8664 folder on installation disk) I can not find the GRE Extension (there is the Sharepoint and Exchange GRE, VMware legacy integration, VMware VAE Integration, with others but no VMware GRE Extension).


    If I look at the vCenter drive, i do not see the "webapps\VMWareGRE" folder.

    Also I don't find the "vmwgre_wp.cmd" script, neither on the CM nor on the VC Server.


    I use following Versions:

    - vSphere and vCenter Server : 5.1

    - DataProtector : 7.0 with Patch DPWINBDL_00701


    As said, everything works fine

    - VMbased Backups

    - VMware Site Recovery Manager

    - and so on


    The question(s) I have:

    - is there anything else I can make?

    - cause security requirements, the vCenter server is not part of the domain (just a workgroup server)


    Any input will be appreciated.





  • Hi ,


    Could you please try delete the vCenter server delete and add it again?

    0.delete the directory webapps\VMWareGRE and remove gre plugin from http://Vc/mob ->content->extension manager.

    1.Add the VC server as a client with Virtual Environment Agent.

    2.Import the same client as Virtual Center server.

    3.Now add components for Vmware GRE and extension.


  • Hello Ranjit -


    I am having exact issue with DP 7.00 and vCenter 5.1 (cab't install web plug in). the solution you provided isn't working, In fact it does not apply for vCenter 5.1 I guess. 





    EMC Corp.

  • Hi


    try if You can get following patches:




    After installing these patches, I could install the GRE Plugin





Reply Children
  • kindly share the download link for downloading the SSPNT700_014 and so on pathces to install GRE web plugins


  • Hi,


    you need to open up a support call to get those SSPs 

  • Hi!,

    I have the same error but before the post-installation script. I go open a case with support for the patch, atfer that, i post the results.


    Anyway, i see this errors in debug.log:


    14/03/2013 10:12:01  OMNICC.8776.9000 ["/cli/omnicc.c $Rev: 30902 $ $Date:: 2012-05-10 15:15:01":800] A.07.00 b101
    Could not open host format file C:\Program Files\OmniBack\config\client\modules\vmwaregre_webplugin.conf.
    [install_service]: SetServiceStatus(STOPPED) failed, err=6


    Is it same thing?



  • Hi,

    After the installation of SSPNT700_014, the integration should create the directory and the files correctly. But, the post installation fails, the debug.log shows:


    3/19/2013 10:09:52 AM  vmwaregre-agent.exe.7760.736 ["integ/vmware/GRE/Agent/vCenter/SessionFactory.cpp $Rev: 13528 $ $Date:: 2010-09-29 10:58:29":150] A.07.00 bSSPNT700_014
    [VMware::vCenter::SessionFactory::LoginStandardSecurity] Exception: Log on to Virtual Center could not be performed.
     Details: Web service error: Cannot complete login due to an incorrect user name or password.
    2013-03-19 10:09:52 VMWGRE_WP.5184 ('/integ/perl/ 30893':1681) A.07.00 b101
    vmwaregre-agent -register_plugin returned *RETVAL*18000
    Log on to Virtual Center could not be performed.
    Log on to Virtual Center could not be performed.
    Details:Web service error: Cannot complete login due to an incorrect user name or password.


    The VEPA backup and restore is working fine. Only the installation of GRE web Plugin fails...


    YES: the password is correct.


    Any idea ?



  • Hi Diogo,


    I can replicate this error with correct password: 

    [ -2] 2013-03-20 11:30:21 ("integ/vmware/GRE/Agent/vCenter/SessionFactory.cpp $Rev: 13528 $ $Date:: 2010-09-29 10:58:29":150) A.07.00 bSSPNT700_014
    [ -2] [VMware::vCenter::SessionFactory::LoginStandardSecurity] Exception: Log on to Virtual Center vcent51.dp70.local could not be performed.
    Details: Web service error: Cannot complete login due to an incorrect user name or password.


    This happens if in the Vcenter credentials the user is not in format domain\username like -appserver_user "ADMINISTRATOR"  . This is also a problem with Hyper-V environments.

    If I change this in the Login tab for the Vcenter in clients menu repectively the entry in cell_info  to -appserver_user "dp70\ADMINISTRATOR" and then run vmwgre_wp.cmd on the Vcenter it registers the plugin fine. 

  • Hi markovdi,


    Tanks for your reply, but the credentials  are in the format that you say.


    Check the  cell_info file in this environment:


    -host "" -os "microsoft amd64 wNT-6.1-S" -cs A.07.00 -da A.07.00 -ma A.07.00 -cc A.07.00 -docs A.07.00 -vepa A.07.00 -vmwaregre_agent A.07.00 -vmwaregre_webplugin A.07.00 -StoreOnceSoftware A.07.00 -appserver_subtype "vcenter" -appserver_type "vmwarehost" -appserver_integrated_security "0" -appserver_cert "" -appserver_pass "Hscgv~'imztoi9.uwn" -appserver_port 443 -appserver_user "domain\user" -appserver_web_root "/sdk -appserver_organization"



    This  server is: CM, MA, Backup Host and the vCenter Server. Windows 2008 R2 SP1.


    The backup of VEPA is OK. Without errors or warnings.



  • Hi Diogo,


    does it run right now, because i've exctly the same error???


    Please could you give me the solution if you have one?


    My mailaccount is