Stopping a StoreOnce copy erroring off falsely?

So I have a line in cron that run a copy every hour.

# Copy the archive logs over to Fenton hourly

13 * * * * /opt/omni/bin/omniobjcopy -replist Hourly_Archive_Log_Copy -scheduled > /tmp/objcopy.$$ 2>&1

 

NOW we get an alarm if there is nothing to copy.  THAT is not an error.  How do I make DP NOT report it?  Folks will get paged for a false alarm.  Is there a way to check for objects before I attempt a copy?

[Normal] From: CSM@sapbck.ssmhc.com "Hourly_Archive_Log_Copy" Time: 1/12/2017 4:13:00 PM

Replication session 2017/01/12-119 started.

[Critical] From: CSM@sapbck.ssmhc.com "Hourly_Archive_Log_Copy" Time: 1/12/2017 4:13:05 PM

No objects to copy. The session will abort.

 

This is from the man page but an example might be nice:

 

To obtain the information about all backed up objects or sessions

containing the objects you want to copy, use the omnidb command.

 

Parents
  • Verified Answer

    Hi Vincent,

    you can control session behavior with following global file variable: 

     

    # SessionStatusWhenNoObjectToCopy=0 or 1 or 2

    # default: 0
    # This option is used by Data Protector to control behavior
    # of object copy session, when there are no objects to copy:
    # 0 - session is marked as failed and critical error is shown
    # 1 - session is marked as successful and warning is issued
    # 2 - session is marked as successful and normal message is issued

Reply
  • Verified Answer

    Hi Vincent,

    you can control session behavior with following global file variable: 

     

    # SessionStatusWhenNoObjectToCopy=0 or 1 or 2

    # default: 0
    # This option is used by Data Protector to control behavior
    # of object copy session, when there are no objects to copy:
    # 0 - session is marked as failed and critical error is shown
    # 1 - session is marked as successful and warning is issued
    # 2 - session is marked as successful and normal message is issued

Children
No Data