Data Protector 10.0 New Scheduler won't work


I downloaded a trial version of DP 10.0 and install on Windows 2012 R2

The new Scheduler don't working for me. When i add a schedule at the new Web UI the specification window is empty and i can't do anything. When i go the backup section and click the "Edit Schedule..." nothing happend.

The migration of the old schedule is failed too.

Did I miss something? Any prerequisite i need?

Thank You!


  • I saw _some_ data, but could not modify a schedule - due to most GUI elements missing.

    This was a quite simple Windows 2012 R2 installation.

    It started to work after I disabled IESC (Internet Explorer Enhanced Security Configuration)

  • I tried this but not help. I think this is not just a GUI issue becouse when i installed the new version the schedule migration is failed too, i tried to migrate the schedules manuali, but faild again. So i think i need to install some API maybe .NET or VC or something, but i try som version of these.

  • Look at the web browser settings. In my case, the proxy setting was the issue. I disabled proxy and scheduler (and also dashboard and telemetry) is now visible.

  • Hi everyone,

    I too have the same issue, I just installed some windows security update and after the restart, when I tried to run data protector and click the edit schedule command from the Backup menu. My edit schedule comes up empty. But before this I had a previous problem starting hp data protector the services can't start properly hpdp-as can't start (1053) - so I tried to repair the installation which kinda fixed that issue but now the edit schedule is not working properly. Any advice?

    Thanks and Regards,

  • Hi Jderama.

    I too have the same issue. I have installed 10.02 patch and am unable to schedule any backups even though I can manually run any backup. I was wondering did you get a fix for this issue?

    One of the forums I have seen suggests that the issue is related to certs and you need to need to regenerate some certificates.?

    Thanks and regards.


  • Same here: Upgraded vrom 9.09 via 10.03 to 10.10 as 9 will be EOL at the end of the year. First the "upgade" did remove a symbolic link that data protector did not create, loosing the database and then assuming it's a new install, which messed up everything. After recovery from that mess, some schedules could be migrated, while others could not.

    So I had opened a support call that turned out not to be very helpful:

    Recerating some certificate made more schedules to be converted (why that?), while the rest of the conversion just hung and needed a restart of the services.

    Still we have one schdule that looks perfectly sane, but the conversion throws an exception (I had send lots of debug logs to support, but they did not tell me that; I found out myself):

    13:44:21,498 ERROR [io.undertow.request] (default task-267) UT005023: Exception handling request to /jce-dispatcher/restws/schedule: org.jboss.resteasy.spi.UnhandledException: java.lang.IllegalArgumentException: End time cannot be before start time"

    What is interesting about

    "End time cannot be before start time"

    is the fact that th schedules do not contain any end time!

    Support suggested to recreate the schedule with the GUI which I had to reject, because our schedules are created by a really intelligent scheduler, so each session for a year is explicitly scheduled once.

    I saw that I can export a schedule (to learn about the format; it's JSON), and then can import it again. My plan is to re-write my schedules in JSON and import them. OK, that takes a lot of time, but DP support seems to take even longer to get the problem fixed.

    The inability to provide a useful error message to the user ("internal error" is all I saw) makes me summarize all that as "Java crap" (because all these systems behave similar, and it's a real pain to isolate the problem).

  • Hi,

    I would recommend to open a support case. This seems to be an issue with the Application Server so there are many possibilities.

    Best Regards

  • Hi Jderama,

    Try this:

    1. Uncheck Do not save encrypted pages to disk ==> Internet Options->Advanced tab->Security->Do not save encrypted pages to disk
    2. Enable and then Disable Internet Explorer Enhanced Security
    3.            Clear all the IE

                                  Temporary Internet Files



     Best Regards

    Close the GUI and re-open it.

  • Hi Ulrich,

    First the "upgade" did remove a symbolic link that data protector did not create, loosing the database and then assuming it's a new install, which messed up everything.

    - Soft Links are not supported in 10.x

    In regards to "End time cannot be before start time" that comes from Quartz, what's interesting is you mention that there's no End time however, the condition that triggers the exception must have endtime =! null, so in your case somehow the endtime is set, I'm not sure if it's the intelligent scheduler that you mention but it could be.

    Could you please share the schedule file?

    Thank you,