Exchange GRE restore - multiple databases visible and not listing correct sessions

Data protector 10.30 on a RHEL Linux Cell
Exchange 2016

Hi all. We have a bit of a strange one (to us anyway!).

Our Exchange team have recently tried to complete an Exchange recovery using the installed Exchange GRE, and the database selection option (the mailbox selection option doesn't work for us and can take hours to come back with anything... that's for another forum post).

When they view the list of Exchange databases, the one they want is listed twice. When they continue with the process they are offered just two available sessions - both from 2019. We can see in the DP GUI that we have regular daily backups but only the two from 2019 are listed within the GRE - whichever of the two databases they select.

Again back in the DP GUI, we could see the old sessions which for some reason were still listed - they should have expired over a year ago. We removed the sessions from the GUI and they have gone, however when we run the command 'omnidb -sess', we still see them in all their glory. There is no media left associated with these as they were exported from the Catalyst store - everything in there now is valid protected data.

Additionally via the GUI, when we list objects for the Exchange DAG, we can still see two instances of the database. The first in the list is made up of the two 2019 backups, and the second in the list has all of the valid, recent backups.

I'm guessing that although the GRE lists the two database options, it's only reporting on the backup sessions 'it comes to first', and isn't as clever as the DP GUI?

It seems we need to remove the objects and sessions from the 2019 backups to remove the duplicates which will hopefully help but at the moment, we're struggling to achieve that. We have removed the sessions and media via the GUI and they have gone as far as the GUI is concerned, but as I mentioned, the 'omnidb -sess' command still lists them. We have tried 'remove version' on the object listed under Internal database/objects. This doesn't error, it just doesn't remove them. We've run database checks which are all clear, and have run 'omnidbutil -purge -dcbf' but those pesky objects are still there.

Any help/suggestions would be appreciated!