Add Virtual Machine to the backup ... takes ages

When backing up from VCenter appliance DP is waiting 7+ hours to add all the virtual machines to the backups as each one takes 5-10 minutes.  Only after that does the backup start.

Obviously there is a caching/timeout and/or connection issue but I don't see it on smaller environments which takes literally minutes for this stage..

This has been going on for quite some time.

Does anyone have the correct settings for this or know why it takes so long?

Call has been opened numerous time with support but they haven't got the the bottom of it.

Thanks 

  • Hello

    Could you please share number for the last support case opened? I would like to check the information provided.

    Best Regards

  • Check the omnirc on the backup host / media agent - is this set? OB2SHUTDOWNFLAGS=9. Cos that has a MASSIVE impact on other queries. Its recommended here for example: https://docs.microfocus.com/itom/Data_Protector:2021.02/ObjectCopySessionFails but what they fail to mention is that it also forces the vepa host to wait for the timeout before looking for the next VM. 

  • Thanks,  

    the ominrc settings for the Cell manager and the media access server are below.

    removing Ob2shutdownflags by commenting them out made no difference when a new job was run but there are so many settings in there -  I'm sure one of them is causing the issue?

    Cell manager:

    OB2_IPC_PROTOCOLINFOTMEOUT=300
    OB2IPCKEEPALIVE=1
    OB2INETTIMEOUT=120
    OB2IPCKEEPALIVETIME=900
    OB2IPCKEEPALIVEINTERVAL=60
    OB2_VEAGENT_VCENTER_CONNECTION_LIMIT=10
    OB2RUNSCRIPT=1
    OB2IPCSECGRACEPERIOD=30
    OB2RECONNECT_ACK=7200
    OB2SHMIPC=0
    OB2RECONNECT_RETRY=1
    OB2INETTIMEOUT=3600
    OB2PORTRANGE=22000-22999
    OB2_IPC_DNSRETRYCOUNT=3
    OB2_IPC_DNSRETRYTIME=10

    media Access server:

    OB2IPCKEEPALIVE=1
    OB2INETTIMEOUT=120
    OB2IPCKEEPALIVETIME=900
    OB2IPCKEEPALIVEINTERVAL=60
    #OB2SHUTDOWNFLAGS=9
    #OB2SHUTDOWNTIMEOUT=180

    OB2_VEAGENT_VCENTER_CONNECTION_LIMIT=5

  • Verified Answer

    I usually set this (to fix the csm copy end error)

    OB2SHUTDOWNFLAGS=9

    OB2SHUTDOWNTIMEOUT=2

    That way the csm copy job ends successfully but I don't introduce too much time between waiting for VMs to display in VE backups.

    Did you restart the DP INET service on the backup host (server with virtual env integ agent installed) after hashing out the variables?

    Also why are you restricting your vcenter connections to 5? What DP version are you using? (I believe that default is 10 in DP10.x)

  • Suggested Answer

    By jove I think you've got it.

    If I copy your settings and remove the limit of 5 vcenter connections +reboots  it all works again.

    All these settings were done by previous tickets we opened with MF  support so its a mystery as to why.

    My greatest thanks for this as obviously it has made a dramatic impact on our whole backup schedule window.

  • Yep, I think if the people who write the code + provide support for the product actually had to support a data protector environment for any extended length of time, there would be significant changes introduced to enhance / improve the user experience! Still it keeps people like me in work so I guess I shouldn't complain too much..... 

    Seasons greetings x