DataProtector 7.00 - VMs do a Full Backup instead a Differencial

Hi,

 

i have a Problem with an existing DataProtector 7.00 Installation and Backup VMs over the VEAgent.

I added my vCenter Server to my DP and want to setup my VMs. Friday Full and Monday till Thursday Differencial.

The "Virtual Machine Settings" are:

- Snapshot Handling: Single

- Enable CBT

- Use CBT

- Use quiescense Snapshots

- Transportation Mode: Fastest

 

I setup a schedule like described befor in the same backup job. My vCenter Server is Version 5.1 U2. My ESXi Servers are Version 5.1.

 

I can create a full backup without a Problem. Sometimes a Diff-Backup on Weekdays works, too. But the most time i get follwing error and a full backup runs instead of a diff-backup:

----------

[Warning] From: VEPALIB_VMWARE@w2k8-back.domain.de "/Datencenter"  Time: 11.06.2014 19:30:18
    Virtual Machine 'w2k8-vcenter01': Could not find valid previous backup ...

[Warning] From: VEPALIB_VMWARE@w2k8-back.domain.de "/Datencenter"  Time: 11.06.2014 19:30:18
[172:151]     Virtual machine 'w2k8-vcenter01': Incremental/Differential backup not enabled.
----------

 

Meanwhile i dont know, where i should start to investigate this issue.

So i please need your help.

 

Thanks!

 

Best Regards

Marco

Parents
  • Do you have 2 different backup specifications, one for Full and one for Differential?

     

    If so, you shouldn't.  You should have a single Backup specification for both, and set the type to Full or Differential in the Schedule tab

     

    This can also be caused by having protection on Full Backups being set too low, so that the Protection expires before a differential backup runs, but, this is pretty rare

  • Hello Bob,

    thanks for your Reply.
    I have 1 Backup Specification.

    The Protection Level is 4 Weeks. I have this error/Problem within one week, too. So i dont think this is my Problem.

    Any other Ideas?

    Thanks!

    Regards
    Marco
  • Hi,

     

    i am using the plain version.

    Do you mean DP Debugs? How can i enable it? Unfortunatelly i dont have so much experience with DP. If you can explain me where i should enable any debugs i will do it.

     

    Thanks.

     

    Best Regards

    Marco

  • You can enable debugging by:

    1. Use -debug option with commands.

    Ex: #/opt/omni/bin/omnib -oracle8_list 2TBbackup -debug 1-300,C:1024000 2TBbackupDebug.txt

     

    2. Else from Windows GUI, click files on top left -> Preferences -> debugging ; Give filename and select option to start debugging. Restart GUI.

     

    By default, Debugs will be created on /tmp in linux and programdata\omniback\tmp.

     

    Log Level can be 1-100, 1-200, 1-300, 1-500. Last one will generate more number of logs and logs each info. So make sure space usage.

     

  • Hi,

    thanks first.
    I enabled Debug Logging with Log-Level 1-300. I did not uses 1-500 because i can not calculate how much space it will consume.

    In the meanwhile: Are there any other Things i can check? Any other ideas? Are there special Informations i have to look at in the Debug File?

    Thanks.

    Best Regards
    Marco
  • you can  search for the string/part of the strong you get in error message. Probably it will be in BMA/BSM files. After finding the error in the file, check the events/messages prior to this. One of the message can tell you why backup goes through full instead of INCR/DIFF.

     

    Also Check how to get patches(703) and apply them. Then check if everything works fine.

     

    Fyi: Also DP has released major release 8.1.

  • Hello,

     

    one additionally question for the meanwhile:

    How can i disable the Debug Logging again?

     

    I configured following back to the settings before to disable Debugging:

    Range Specificaton: 1-99

    Debug File Name: Debug.txt

    "Do not use these settings in the future": Enabled

     

    After that is restartet just the GUI - not any Windows Services.

    Is this ok?

     

    Thanks!

    Regards

    Marco

  • You have disabled it. That is the procedure to disable logs.

    But what about the problem? Could you find the reason?

  • Set your range to 'Blank;', that is, leave the field empty, and click the button to restart the GUI

     

    By the way, I would never have you debug in this manner, it is too easy to leave debugging on.

     

    Rather, start the gUI from the MS-DOS prompt

     

       cd \Program Files\Omniback\bin

       manager.exe -debug [range, like 1-99] [Post-fix]

     

    So, in your example

     

       manager.exe -debug 1-99 Debug.txt

     

    As soon as you exit the GUI, debugging stops

  • Hello,

    first, sorry for my late response.
    Meanwhile i tried to "analyze" the Debugs Logs. I found the strings from my error message in two Textfiles - but this was not a BMA/BSM file, just "MONITOR" and "GUICORE".

    In the other Files are a lot of Informations i cannot understand. But there are not any string of my Error.

    Any other Suggestions or Ideas? Or is the only thing now i can do an Update of DP? If yes, there are some more questions. How do i install the Patch 7.03? Do i have to install from 7.00 over 7.01 and 7.02 to 7.03 or can i just install 7.03? Any Patch Order or good Informations how to Update DP?

    Many Thanks!

    Best Regards
    Marco
  • I would not recommend that you upgrade to the next patch level yet, it is counter-productive to introduce new vgariables into this problem

     

    IN temrs of capturing the debugs, it appears that you only got debugs from the system running the GUI, not from your cell manager, please check again.  Since you have not specified a hostname or the OS-type of the Cell Manager, I can't be more specific than that

  • Hello Bob_Clark,

    Thanks for your reply.
    The GUI and the Cell Manager runs on the same Host.
    The OS-Type of the Cell Manager is "Windows Server 2008 R2 Standard".

    So i will debug the logs and check again.
    Is there a secific Debug file where i should look for my error?

    Thanks!
    Best Regards
    Marco
Reply Children
No Data