Report lookup_sch fails with "Error creating the report "Interactive": Unknown internal error."

1 Likes
10 months ago
The original issue was that report does not worked. It was failing with this output:
[root@cmname tmp]# omnirpt -report lookup_sch -html -schedule 7
Error creating the report "Interactive":
Unknown internal error.

 

Solution

Seeing debugs I saw this:
---OB2DBG_18743__DBSM_cmname.domain.com_18745-2177308448_rpt_er.txt---
[ 99] 2020-12-18 16:28:44.064 ("/lib/libAdvancedSchedulerInterface/advanced_scheduler_interface_api.cpp $Rev$ $Date$":217)
[ 99] <<=== (4) } /* cacheAllSchedulesOfJobsForReporting */
[ 99]
[ 30] Failed to get all schedules of jobs
[ 30] Error code: . Error message:

That means the command to export did not worked either.
And in fact, it was failing like this:
[root@cmname ~]# omnidbutil -export_schedules -all
Failed to get jobs for export. Error message:
Not all schedules were exported successfully. Error message:

Then, in the debugs I saw this:
---OB2DBG_17539__DBSM_cmname.domain.com_17543-2690848544_exp_sch.txt---
[ 99] 2020-12-18 16:26:36.677 ("/sm/smcmn/smutil.c $Rev$ $Date:: $:":2963)
[ 99] <<=== (4) } /* GetEncDecText */
[ 99]
[ 10] [ProcessKeycloakTokenMessage] webUserName[root
*
*]
[ 10] password not found in IDB

To solve this we reset that password with this command: omniusers -resetpass -name "root
*
*" -pass *Password1
After that the report worked.

Labels:

Support Tip
Comment List
Anonymous
Related Discussions
Recommended