Restore to non-original config fails with "[172:172] Error creating Virtual

1 Likes
over 1 year ago

Problem

DP 9.09.
CM same Backup Host running in Windows Server 2012 R2
ESXi 6.0 U3

Succesfully can backup machines from the ESXi. No errors there.
Restore using the original location works with no issues.
Restore modifying the configuration of the restore, selecting a diferent location fails with this message:

[Major] From: VEPALIB_VMWARE@backuphost.domain.com "/ha-datacenter" Time: 4/23/2020 6:12:17 PM
[172:172]  Error creating Virtual Machine 'VMNAME'.

Cause

Debug logs shows this:

---OB2DBG_15648_2020-04-23-3_VEPALIB_VMWARE_backuphost.domain.com_15808-17268_debug0422.txt---
[ 99] 2020-04-23 10:09:17.210 ("/integ/vep/vepa/Plugins/Vmware/VmwareHelpers/ManagedObjectLocator.cpp $Rev: 45074 $ $Date:: 2014-10-21 11:23:14 ":230)
[ 99] <<=== (12) }  /* ManagedObjectLocator::findByName */
[ 99]
[ 20] [ConfigUtil::createVM] Unable to find object with (name=esxiname.domain.com of type= ClusterComputeResource)
[ 20] [ConfigUtil::createVM] Throwing exception: class VepaException
-----------------------------

Name resolution from CM, ESXi and datastores are good and working with no issues.

We checked the MOB and the name reported there is the shortname, not the FQDN, it was just: esxiname

To check the MOB connect here: https://esxiname.domain.com/mob/?moid=ha-host
And find property named "name".

This is failing because Data Protector is searching for the FQDN as resource when the ESXi identifies it self with the short name.

Fix

To solve the problem, we added the ESXI into DP with the shortname as well.

Using the GUI or command it resolves the FQDN, to add it we opened the cell_info file in the CM (ProgramData\OmniBack\Config\Server\cell or /etc/opt/omni/server/cell), copied the entire line with the ESXi full name and copied there, then remove the domain and keep just the short name.

After that, we go to Restore the VM and when we select the destination, we selected the shortname instead of the FQDN.

The restore worked.

Labels:

Support Tip
Other
Comment List
Anonymous
Related Discussions
Recommended