(DP) Support Tip: systemd filling up Messages Log


Error Message
After the installation of DP10.80 on RHEL7.7, Backups are working fine , but so many messages are logged in /var/log/messages as follows .

Oct 22 10:57:27 hostname systemd: [/usr/lib/systemd/system/omni.socket:9] Unknown lvalue 'MaxConnectionsPerSource' in section 'Socket'
Oct 22 10:57:29 hostname systemd: omni@#-xxx.xxx.xxx.xxx:5565-xxx.xxx.xxx.xxx:53080.service: main process exited, code=exited, status=1/FAILURE
Oct 22 10:57:29 hostname systemd: Unit omni@#-xxx.xxx.xxx.xxx:5565-xxx.xxx.xxx.xxx:53080.service entered failed state.
Oct 22 10:57:29 hostname systemd: omni@#-xxx.xxx.xxx.xxx:5565-xxx.xxx.xxx.xxx:53080.service failed.
Oct 22 13:07:12 hostname systemd: omni@#-xxx.xxx.xxx.xxx:5565-xxx.xxx.xxx.xxx:33102.service: main process exited, code=exited, status=2/INVALIDARGUMENT
Oct 22 13:07:12 hostname systemd: Unit omni@#-xxx.xxx.xxx.xxx:5565-xxx.xxx.xxx.xxx:33102.service entered failed state.
Oct 22 13:07:12 hostname systemd: omni@#-xxx.xxx.xxx.xxx:5565-xxx.xxx.xxx.xxx:33102.service failed.

1. Regarding "Main process exited, code=exited, status=1/FAILURE"
It's a known issue(KM03709810) and we have a hotfix for DP10.70 only .(as of Oct 2020)
If systemd needs to be used for DP INET, we will prepare a hotfix for DP10.80, but the use of xinetd should be considered on the system .(see below)

2. systemd was chosen to set up DP INET unexpectedly
systemd is supported on RHEL 8.0 and later versions, and on SLES 15 and later versions.

Ref) https://docs.microfocus.com/itom/Data_Protector:2020.08/ReleaseLog

Because systemd of RHEL7 doesn't support MaxConnectionsPerSource option ,
"Unknown lvalue 'MaxConnectionsPerSource' in section 'Socket'" is logged .

Ref) man systemd.socket

During the installation of DP, INET will be configured by the following order .

# 1. check for xinetd
if [ -f /etc/xinetd.conf ]; then

# 2 xinetd not found, so check for "systemd"
if [ -z "${INETD_TYPE}" -a -f /etc/systemd/system.conf ]; then

# 3. check for inetd if xinetd not found
if [ -z "${INETD_TYPE}" -a -f /etc/inetd.conf ]; then

So, if xinetd was not configured but systemd has already been set up , systemd is used to set up DP INET even though it's RHEL7 system .

Workaround / Fix
To correct the current situation, DP INET needs to be reconfigured with xinetd manually as follows .

1. /opt/omni/sbin/omnisv.sh stop
2. /opt/omni/sbin/dpsvcsetup.sh -uninstall
3. Configure xinetd
(confirm if xinetd is active by systemctl status xinetd)
4. /opt/omni/sbin/dpsvcsetup.sh -install
5. /opt/omni/sbin/omnisv.sh start

Ref) the dpsvcsetup.sh utility : https://docs.microfocus.com/itom/Data_Protector:2020.08/SysPrepMaintenanceTasks


Support Tip
Comment List
  • Hello all, 

    The fix for 10.80 is now available too: DP1080_b134_OCTCR19Q970054_HF1

    You can request it to support. 



    Victor Andrés Fallas Salazar
    DP L3 Technical Support Engineer
    San José, Costa Rica

    Please consider to give a like, and if it solved your issue, consider to mark it as the solution.