DP 10.x NETIO thread did not connect

2 Likes

Symptoms

The file system backup got below error:

[Critical] From: VBDA@server1 "backuplog"  Time: 15/04/2020 16:18:52
NETIO thread did not connect => aborting.

[Major] From: BSM@cell.manager "backuplog"  Time: 15/04/2020 16:19:28
[61:1005]   Got unexpected close from VBDA on server1.

Diagnosis

 It seems Encrypted Control Communication (ECC) is still enabled on the DA client. ECC was the secure communication mechanism used in versions prior to 10.X DP components.

This looks to be the root of this error.

[ 99] 2020-04-17 09:38:29.678 ("/lib/cmn/win32cmn.c $Rev$ $Date::                      $:":630)
[ 99] ===>> (3) CmnGetFile {
[ 99]   Args: path:C:\ProgramData\OmniBack\config\client\config
[ 99]

[ 99] 2020-04-17 09:38:29.678 ("/lib/cmn/win32cmn.c $Rev$ $Date::                      $:":669)
[ 99] <<=== (3) }  /* CmnGetFile */
[ 99]   RetVal: (ptr) 0000000000AF8720
[ 99]
[199] [file_load] loaded version:1, size:622, length:1
[199] [Config_load] return at 349: 1
[260] [SSL_NegotiateConnect] 

Solution

ECC needs to be disabled here as both DA and MA clients are on 10.X versions
Delete the file C:\ProgramData\OmniBack\config\client\config. This is the ECC configuration file.

As a reference, please see the below upgrade prerequisites:

https://docs.microfocus.com/itom/Data_Protector:2019.05/UpgradePrereq 

Additional Information

Labels:

Support Tip
Comment List
  • Isn't ECC newly introduced in v10? My FS this morning that has been backing up  fine all of a sudden gave a "NETIO thread did not connect" error. Looking at the "C:\ProgramData\OmniBack\config\client\config" file shows "encryption=;" What does this mean?

Related
Recommended