Filr 24.1.1 - 2 files listed and will NOT be installed

After the upgrade to Filr 24.1 and today to Filr 24.1.1  two files will be listed!

can we ignore this or do anybody know how to solve this?

zypper up
Refreshing service 'nu_novell_com'.
Loading repository data...
Reading installed packages...

The following 2 package updates will NOT be installed:
samba-client-32bit samba-client-libs-32bit
Nothing to do.

  • I will test it this evening, Claude. I cannot stop customers now.

    I have some customers where filr cannot be updated to 24.1. I assume that 24.1.1 will help them.

    For all other admins who are already on Filr 24.1 (successful update before) nothing will happen.

    So let's hope for some more successful updates ...


    Use "Verified Answers" if your problem/issue has been solved!

  • Different result on my fine working Filr 24.1.1. enviroment

    In the appliance management, no needed patches

    on the appliances

    Nothing with Samba packages

    And another thing

    tune btrfs, disable yast and timeline snapshots and also disable quotas.

    After this the filr heads have good performance

  • As always, what you read here is based on my experience and knowledge from the field.

    Filr 5.0 uses its own repos. Although the Filr runs on SLES 15 SP 4, there is a separate OS repo which provides the necessary files for the Filr update. With the update of the Filr instance via the VAAdmin the instance was upgraded to 24.1.1, in the VAAdmin only an update concerning 24.1.1. was offered. There were also updates for SLES 15 SP4 in the CLI. From experience, zypper up or zypper patch on the Filr should be executed with caution, it can lead to undesirable effects, I already had the issue with Phyton and Filr.

    Perhaps OT Support can comment here again.

    Finally one more thing. The snapper and btrfs snapshots have often brought systems back to a stable state after failed updates. Everyone has to decide for themselves what is important to them. Saw off branches and realize afterwards that you are on the wrong side.

    George

    Filr Repos on Filr Appliance

    # | Alias | Name | Enabled | GPG Check | Refresh
    --+------------------------------+----------------+---------+-----------+--------
    1 | nu_novell_com:Filr-5-OS | Filr-5-OS | Yes | (r ) Yes | Yes
    2 | nu_novell_com:Filr-5-Updates | Filr-5-Updates | Yes | (r ) Yes | Yes
    ~ #

    zypper lu after Update in vaadmin console


    Refreshing service 'nu_novell_com'.
    Loading repository data...
    Reading installed packages...
    S | Repository | Name                 | Current Version      | Available Version Arch
    --+------------+----------------------+----------------------+------------------ ----+-------
    v | Filr-5-OS  | libhidapi-hidraw0    | 0.10.1-1.6           | 0.10.1-150300.3.2.1  | x86_64
    v | Filr-5-OS  | libsource-highlight4 | 3.1.8-150000.3.2.1   | 3.1.8-150000.3.4.1   | x86_64
    v | Filr-5-OS  | libxmlsec1-1         | 1.2.28-150100.7.13.4 | 1.2.37-150400.14.3.4 | x86_64
    v | Filr-5-OS  | libxmlsec1-openssl1  | 1.2.28-150100.7.13.4 | 1.2.37-150400.14.3.4 | x86_64
    v | Filr-5-OS  | python3-psutil       | 5.8.0-150300.3.3.2   | 5.9.1-150300.3.6.1   | x86_64
    v | Filr-5-OS  | python3-requests     | 2.24.0-150300.3.3.1  | 2.25.1-150300.3.6.1  | noarch

  • Hello Diethmar,

    this only applies to the use of external repos from OT

    please check with your customers whether they are using FW with GeoIP blocking. Check whether the customer checks for https data streams in the FW, i.e. https is used in the FW to detect anamalies, in which case it may be that the certificates of the FW are given to the Filr instead of those from the external repos. This can be a source of errors. Another thing is the name server which is used by the Filr, does it get authoritative answers for the patch sources? . What has almost always been successful so far is to go past a proxy for the Filr update and run a zypper ref on the cli at the beginning and then install the patches with the vaadmin. I know you are a very experienced professional, maybe there was some helpful info.

    I have done several installations to the current version without much trouble. That's not quite right, I'll have to take another deep look at the Filr integration in GroupWise. I have the issue that the URL from GroupWise is incorrect if the recipient uses an IMAP or POP mail service.

    George

  • 24.1.1 did not help. Update runs through without any errors. But login window will not be available after restart.

    Fortunately I could return to a snapshot. A case has been opened some time ago, but support is very slow ...

    Just now there are only two customers (both small) running into this issue.


    Use "Verified Answers" if your problem/issue has been solved!

  • What is the result of "zypper in samba-client-32bit samba-client-libs-32bit"? This will usually indicate why the packages were ignored.

  • i don't want a new experience and new trouble and had open a case by ot support, but no response since any weeks.

    the answer was to wait to upgrade 24.1.1 and after this upgrade the same situation and i had remember for my open case!

    No response, no solution!

    Do you have the same experience with OT-Support?

  • Claude, if you update to 24.1.1, do not forget to take a snapshot.

    However support does not recommend to run updates outside of the web interface (i.e. with zypper). Except if there are instructions by support to do so ...

    Most of my customer were successful in update/upgrading. However I have two environments which are still on 23.4 because any update activities fail. A case has been opened but no further progress ... Thinking


    Use "Verified Answers" if your problem/issue has been solved!

  • In my cases this document helped: https://portal.microfocus.com/s/article/KM000027103?language=en_US

    I attended the filr webinar yesterday and Kyle mentioned this document. Thank you, Kyle. Support was not able to fix it for about three weeks ...


    Use "Verified Answers" if your problem/issue has been solved!

  • One *very* important note here, hence in caps:

    DO NOT EVER USE "ZYPPER UP" IN ANY MICROFOCUS/OPENTEXT PRODUCT. ALWAYS USE "ZYPPER PATCH".

    That being said, it is perfectly ok to use zypper in cli on filr appliances. The appliance interface does nothing other than that (you can see with ps if you want).

    As for your error. The version of samba-client-libs-32 your update attempts to install should not be seen. Please verify your repositories on your server.

    It is of course possible, that the repos erroneously had that version included for a while, and you were just unlucky.