This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Novell Data Synchronizer Mobility Pack Update 3

Hello All,

Novell Data Synchronizer Mobility Pack Update 3 has been released in patch
finder (


  • Hi dKnudson

    The solution is following:
    I used sslMethod 3 for my environment..


    Selecting a Specific Version of SSL
    By default, the Mobility Connector accepts connections from mobile devices
    that use SSLv3 and TLSv1, but rejects connections from mobile devices that
    use SSLv2. If a userâ€Tms mobile device tries to connect using SSLv2, the user
    receives an error and cannot connect. You can enable and disable different
    versions of SSL protocols and also specify the cipher to use with the
    desired protocol.

    1.In Synchronizer Web Admin, click the Mobility Connector to display the
    Mobility Connector Configuration page, then click Edit XML Source to display
    the Connector XML Source window.

    2.Add the following tags between the <custom> and </custom> tags:

    3.In the <sslMethod> tag, replace value with any of the following values:

    SSL Version

    1 (not recommended)



    All of the above
    3 (not recommended)

    SSLv3 and TLSv1
    5 (default)

    4.In a terminal window, use the following command to determine the ciphers
    that are available on your system:

    openssl ciphers -ssl3
    5.In the <sslCiphers> tag in the Connector XML Source window, replace list
    with the desired values as provided by the openssl command.

    6.Click Save XML to save your changes, then click Home to return to the main
    Synchronizer Web Admin page.

    7.Restart the Mobility Connector to put the desired SSL protocol and ciphers
    into effect.

    "dknudson" schrieb im Newsbeitrag

    My update didn't go so well... I ran the and it installed
    fine, restarted the services and users could not connect. Tried
    restarting server a couple times too.
    Everything looks good that I can see, LDAP auth works on the webpage
    login, but the sync fails on the device, like it can't connect to the
    server anymore...
    Any ideas on what I can try next? Thank you.

    dknudson's Profile:
    View this thread:

  • Hi Smily

    Do you work with self signed certificates? If this is the case, you have to
    reimport the certificates in your device.


    "smily 03" schrieb im Newsbeitrag

    I've run into the same issue (thread here:
    ) - we still haven't found a resolution for the problem, which seems to
    be affecting original Droids and some iPhones.

    If it helps any, I'll post my Mobility XML content here; the server
    itself has been restarted but that didn't help either:


    smily_03's Profile:
    View this thread:

  • Ok, we got this resolved last night, wanted to let you all know what the cause was in case you experience it as well.

    Ultimately it ended up being from some bad/misplaced items in the GroupWise accounts of a couple of our users that had caused their initial sync to fail. With the original version of NDS, if the initial sync failed, it would still allow the device to connect to the system, however, with the latest version, that is no longer the case.

    I worked with a Novell support rep (who was really really helpful and knowledgeable by the way - kudos to Mukesh Jethwani :) ) and we went through the GroupWise accounts of the users who were having the problem, and this is what we found:

    One user had drug their Documents folder inside of their address book, which we drug back out under their mailbox.
    One user had drug one of their subcalendars into their Cabinet, which we drug back into their calendar.
    One user had old "xxxx.dup" and "xxxx.dup1" copies of their address books from the old GW5.5 Mac client, which we deleted.
    We'll be looking into the accounts of the other users experiencing the problem as they stop by our office.

    After making those changes and doing a "re-init" on their account in NDS, they were able to connect fine, so the error about security policies was just how their devices were interpreting the messages that were returned to them by the server.