This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Groupwise mobility service fails installation 18.4.2

see subject. many tries and hours of research but no succsess. 

After entering host admin etc. I get AttributeError: module 'lib' has no attribute 'OpenSSL_add_all_algorithms'

and asking starts again GroupWise Administration Agent hostname 

Please help

Rainer

Parents
  • This gives very little info so make sure the SLES modules/extension as mentioned in the requirements are installed, the server itself is registered and the GW admin certificates are all correct. Otherwise provide more details as OS/service pack used, GMS version and build you trying to install etc.

  • Thanks for answer my config is:

    NAME="SLES"
    VERSION="15-SP4"
    VERSION_ID="15.4"
    PRETTY_NAME="SUSE Linux Enterprise Server 15 SP4"
    ID="sles"
    ID_LIKE="suse"
    ANSI_COLOR="0;32"
    CPE_NAME="cpe:/o:suse:sles:15:sp4"

    + latest patches

    GroupWise is 18.4.2

    Mobility is groupwise-mobility-service-18.4.2-x86_64.iso

    Required modules installed

    Certificates should be ok, the admin console has commercial certificates to eliminate browser warnings

    Following the install log file:

    <code>

    Starting GMS install: Wed Jan 4 09:01:13 CET 2023
    GroupWise Administration host: gw1a.muekno.de
    GroupWise Administration port: 9710
    GroupWise Administrator user name: admin
    Please check the entries and try again
    Starting GMS install: Wed Jan 4 09:04:31 CET 2023
    NEW INSTALL
    Installing postgreSQL...
    Refreshing service 'Basesystem_Module_15_SP4_x86_64'.
    Refreshing service 'Certifications_Module_15_SP4_x86_64'.
    Refreshing service 'Containers_Module_15_SP4_x86_64'.
    Refreshing service 'Desktop_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Development_Tools_Module_15_SP4_x86_64'.
    Refreshing service 'Legacy_Module_15_SP4_x86_64'.
    Refreshing service 'Python_3_Module_15_SP4_x86_64'.
    Refreshing service 'SUSE_Linux_Enterprise_Server_15_SP4_x86_64'.
    Refreshing service 'SUSE_Package_Hub_15_SP4_x86_64'.
    Refreshing service 'Server_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Web_and_Scripting_Module_15_SP4_x86_64'.
    Loading repository data...
    Reading installed packages...
    'postgresql-server' is already installed.
    No update candidate for 'postgresql-server-15-150400.4.6.2.noarch'. The highest available version is already installed.
    Resolving package dependencies...
    Nothing to do.
    Refreshing service 'Basesystem_Module_15_SP4_x86_64'.
    Refreshing service 'Certifications_Module_15_SP4_x86_64'.
    Refreshing service 'Containers_Module_15_SP4_x86_64'.
    Refreshing service 'Desktop_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Development_Tools_Module_15_SP4_x86_64'.
    Refreshing service 'Legacy_Module_15_SP4_x86_64'.
    Refreshing service 'Python_3_Module_15_SP4_x86_64'.
    Refreshing service 'SUSE_Linux_Enterprise_Server_15_SP4_x86_64'.
    Refreshing service 'SUSE_Package_Hub_15_SP4_x86_64'.
    Refreshing service 'Server_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Web_and_Scripting_Module_15_SP4_x86_64'.
    Loading repository data...
    Reading installed packages...
    'postgresql-contrib' is already installed.
    No update candidate for 'postgresql-contrib-15-150400.4.6.2.noarch'. The highest available version is already installed.
    Resolving package dependencies...
    Nothing to do.
    Installing ImageMagick...
    Refreshing service 'Basesystem_Module_15_SP4_x86_64'.
    Refreshing service 'Certifications_Module_15_SP4_x86_64'.
    Refreshing service 'Containers_Module_15_SP4_x86_64'.
    Refreshing service 'Desktop_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Development_Tools_Module_15_SP4_x86_64'.
    Refreshing service 'Legacy_Module_15_SP4_x86_64'.
    Refreshing service 'Python_3_Module_15_SP4_x86_64'.
    Refreshing service 'SUSE_Linux_Enterprise_Server_15_SP4_x86_64'.
    Refreshing service 'SUSE_Package_Hub_15_SP4_x86_64'.
    Refreshing service 'Server_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Web_and_Scripting_Module_15_SP4_x86_64'.
    Loading repository data...
    Reading installed packages...
    'ImageMagick' is already installed.
    No update candidate for 'ImageMagick-7.1.0.9-150400.6.9.1.x86_64'. The highest available version is already installed.
    Resolving package dependencies...
    Nothing to do.
    Installing python-openssl...
    Refreshing service 'Basesystem_Module_15_SP4_x86_64'.
    Refreshing service 'Certifications_Module_15_SP4_x86_64'.
    Refreshing service 'Containers_Module_15_SP4_x86_64'.
    Refreshing service 'Desktop_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Development_Tools_Module_15_SP4_x86_64'.
    Refreshing service 'Legacy_Module_15_SP4_x86_64'.
    Refreshing service 'Python_3_Module_15_SP4_x86_64'.
    Refreshing service 'SUSE_Linux_Enterprise_Server_15_SP4_x86_64'.
    Refreshing service 'SUSE_Package_Hub_15_SP4_x86_64'.
    Refreshing service 'Server_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Web_and_Scripting_Module_15_SP4_x86_64'.
    Loading repository data...
    Reading installed packages...
    'python3-pyOpenSSL' is already installed.
    No update candidate for 'python3-pyOpenSSL-21.0.0-150400.3.3.1.noarch'. The highest available version is already installed.
    Resolving package dependencies...
    Nothing to do.
    Installing openssl...
    Refreshing service 'Basesystem_Module_15_SP4_x86_64'.
    Refreshing service 'Certifications_Module_15_SP4_x86_64'.
    Refreshing service 'Containers_Module_15_SP4_x86_64'.
    Refreshing service 'Desktop_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Development_Tools_Module_15_SP4_x86_64'.
    Refreshing service 'Legacy_Module_15_SP4_x86_64'.
    Refreshing service 'Python_3_Module_15_SP4_x86_64'.
    Refreshing service 'SUSE_Linux_Enterprise_Server_15_SP4_x86_64'.
    Refreshing service 'SUSE_Package_Hub_15_SP4_x86_64'.
    Refreshing service 'Server_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Web_and_Scripting_Module_15_SP4_x86_64'.
    Loading repository data...
    Reading installed packages...
    'openssl' is already installed.
    No update candidate for 'openssl-1.1.1l-150400.1.5.noarch'. The highest available version is already installed.
    Resolving package dependencies...
    Nothing to do.
    Installing python-lxml...
    Refreshing service 'Basesystem_Module_15_SP4_x86_64'.
    Refreshing service 'Certifications_Module_15_SP4_x86_64'.
    Refreshing service 'Containers_Module_15_SP4_x86_64'.
    Refreshing service 'Desktop_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Development_Tools_Module_15_SP4_x86_64'.
    Refreshing service 'Legacy_Module_15_SP4_x86_64'.
    Refreshing service 'Python_3_Module_15_SP4_x86_64'.
    Refreshing service 'SUSE_Linux_Enterprise_Server_15_SP4_x86_64'.
    Refreshing service 'SUSE_Package_Hub_15_SP4_x86_64'.
    Refreshing service 'Server_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Web_and_Scripting_Module_15_SP4_x86_64'.
    Loading repository data...
    Reading installed packages...
    'python3-lxml' is already installed.
    No update candidate for 'python3-lxml-4.7.1-150200.3.10.1.x86_64'. The highest available version is already installed.
    Resolving package dependencies...
    Nothing to do.
    Installing python3-psycopg2...
    Refreshing service 'Basesystem_Module_15_SP4_x86_64'.
    Refreshing service 'Certifications_Module_15_SP4_x86_64'.
    Refreshing service 'Containers_Module_15_SP4_x86_64'.
    Refreshing service 'Desktop_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Development_Tools_Module_15_SP4_x86_64'.
    Refreshing service 'Legacy_Module_15_SP4_x86_64'.
    Refreshing service 'Python_3_Module_15_SP4_x86_64'.
    Refreshing service 'SUSE_Linux_Enterprise_Server_15_SP4_x86_64'.
    Refreshing service 'SUSE_Package_Hub_15_SP4_x86_64'.
    Refreshing service 'Server_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Web_and_Scripting_Module_15_SP4_x86_64'.
    Loading repository data...
    Reading installed packages...
    'python3-psycopg2' is already installed.
    No update candidate for 'python3-psycopg2-2.8.5-5.7.1.x86_64'. The highest available version is already installed.
    Resolving package dependencies...
    Nothing to do.
    Refreshing service 'Basesystem_Module_15_SP4_x86_64'.
    Refreshing service 'Certifications_Module_15_SP4_x86_64'.
    Refreshing service 'Containers_Module_15_SP4_x86_64'.
    Refreshing service 'Desktop_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Development_Tools_Module_15_SP4_x86_64'.
    Refreshing service 'Legacy_Module_15_SP4_x86_64'.
    Refreshing service 'Python_3_Module_15_SP4_x86_64'.
    Refreshing service 'SUSE_Linux_Enterprise_Server_15_SP4_x86_64'.
    Refreshing service 'SUSE_Package_Hub_15_SP4_x86_64'.
    Refreshing service 'Server_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Web_and_Scripting_Module_15_SP4_x86_64'.
    Loading repository data...
    Reading installed packages...
    'patch' is already installed.
    No update candidate for 'patch-2.7.6-150000.5.3.1.x86_64'. The highest available version is already installed.
    Resolving package dependencies...
    Nothing to do.
    Refreshing service 'Basesystem_Module_15_SP4_x86_64'.
    Refreshing service 'Certifications_Module_15_SP4_x86_64'.
    Refreshing service 'Containers_Module_15_SP4_x86_64'.
    Refreshing service 'Desktop_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Development_Tools_Module_15_SP4_x86_64'.
    Refreshing service 'Legacy_Module_15_SP4_x86_64'.
    Refreshing service 'Python_3_Module_15_SP4_x86_64'.
    Refreshing service 'SUSE_Linux_Enterprise_Server_15_SP4_x86_64'.
    Refreshing service 'SUSE_Package_Hub_15_SP4_x86_64'.
    Refreshing service 'Server_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Web_and_Scripting_Module_15_SP4_x86_64'.
    Loading repository data...
    Reading installed packages...
    'wget' is already installed.
    No update candidate for 'wget-1.20.3-150000.3.15.1.x86_64'. The highest available version is already installed.
    Resolving package dependencies...
    Nothing to do.
    Refreshing service 'Basesystem_Module_15_SP4_x86_64'.
    Refreshing service 'Certifications_Module_15_SP4_x86_64'.
    Refreshing service 'Containers_Module_15_SP4_x86_64'.
    Refreshing service 'Desktop_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Development_Tools_Module_15_SP4_x86_64'.
    Refreshing service 'Legacy_Module_15_SP4_x86_64'.
    Refreshing service 'Python_3_Module_15_SP4_x86_64'.
    Refreshing service 'SUSE_Linux_Enterprise_Server_15_SP4_x86_64'.
    Refreshing service 'SUSE_Package_Hub_15_SP4_x86_64'.
    Refreshing service 'Server_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Web_and_Scripting_Module_15_SP4_x86_64'.
    Loading repository data...
    Reading installed packages...
    'dialog' is already installed.
    No update candidate for 'dialog-1.3-3.3.7.x86_64'. The highest available version is already installed.
    Resolving package dependencies...
    Nothing to do.
    Refreshing service 'Basesystem_Module_15_SP4_x86_64'.
    Refreshing service 'Certifications_Module_15_SP4_x86_64'.
    Refreshing service 'Containers_Module_15_SP4_x86_64'.
    Refreshing service 'Desktop_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Development_Tools_Module_15_SP4_x86_64'.
    Refreshing service 'Legacy_Module_15_SP4_x86_64'.
    Refreshing service 'Python_3_Module_15_SP4_x86_64'.
    Refreshing service 'SUSE_Linux_Enterprise_Server_15_SP4_x86_64'.
    Refreshing service 'SUSE_Package_Hub_15_SP4_x86_64'.
    Refreshing service 'Server_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Web_and_Scripting_Module_15_SP4_x86_64'.
    Loading repository data...
    Reading installed packages...
    'logrotate' is already installed.
    No update candidate for 'logrotate-3.18.1-150400.3.7.1.x86_64'. The highest available version is already installed.
    Resolving package dependencies...
    Nothing to do.
    Installing python3-requests...
    Refreshing service 'Basesystem_Module_15_SP4_x86_64'.
    Refreshing service 'Certifications_Module_15_SP4_x86_64'.
    Refreshing service 'Containers_Module_15_SP4_x86_64'.
    Refreshing service 'Desktop_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Development_Tools_Module_15_SP4_x86_64'.
    Refreshing service 'Legacy_Module_15_SP4_x86_64'.
    Refreshing service 'Python_3_Module_15_SP4_x86_64'.
    Refreshing service 'SUSE_Linux_Enterprise_Server_15_SP4_x86_64'.
    Refreshing service 'SUSE_Package_Hub_15_SP4_x86_64'.
    Refreshing service 'Server_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Web_and_Scripting_Module_15_SP4_x86_64'.
    Loading repository data...
    Reading installed packages...
    'python3-requests' is already installed.
    No update candidate for 'python3-requests-2.24.0-1.24.noarch'. The highest available version is already installed.
    Resolving package dependencies...
    Nothing to do.
    Installing python3-aniso8601...
    Refreshing service 'Basesystem_Module_15_SP4_x86_64'.
    Refreshing service 'Certifications_Module_15_SP4_x86_64'.
    Refreshing service 'Containers_Module_15_SP4_x86_64'.
    Refreshing service 'Desktop_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Development_Tools_Module_15_SP4_x86_64'.
    Refreshing service 'Legacy_Module_15_SP4_x86_64'.
    Refreshing service 'Python_3_Module_15_SP4_x86_64'.
    Refreshing service 'SUSE_Linux_Enterprise_Server_15_SP4_x86_64'.
    Refreshing service 'SUSE_Package_Hub_15_SP4_x86_64'.
    Refreshing service 'Server_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Web_and_Scripting_Module_15_SP4_x86_64'.
    Loading repository data...
    Reading installed packages...
    'python3-aniso8601' is already installed.
    No update candidate for 'python3-aniso8601-9.0.1-bp154.1.28.noarch'. The highest available version is already installed.
    Resolving package dependencies...
    Nothing to do.
    Installing python3-networkx...
    Refreshing service 'Basesystem_Module_15_SP4_x86_64'.
    Refreshing service 'Certifications_Module_15_SP4_x86_64'.
    Refreshing service 'Containers_Module_15_SP4_x86_64'.
    Refreshing service 'Desktop_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Development_Tools_Module_15_SP4_x86_64'.
    Refreshing service 'Legacy_Module_15_SP4_x86_64'.
    Refreshing service 'Python_3_Module_15_SP4_x86_64'.
    Refreshing service 'SUSE_Linux_Enterprise_Server_15_SP4_x86_64'.
    Refreshing service 'SUSE_Package_Hub_15_SP4_x86_64'.
    Refreshing service 'Server_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Web_and_Scripting_Module_15_SP4_x86_64'.
    Loading repository data...
    Reading installed packages...
    'python3-networkx' is already installed.
    No update candidate for 'python3-networkx-2.0-3.2.8.noarch'. The highest available version is already installed.
    Resolving package dependencies...
    Nothing to do.
    Installing python3-bleach...
    Refreshing service 'Basesystem_Module_15_SP4_x86_64'.
    Refreshing service 'Certifications_Module_15_SP4_x86_64'.
    Refreshing service 'Containers_Module_15_SP4_x86_64'.
    Refreshing service 'Desktop_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Development_Tools_Module_15_SP4_x86_64'.
    Refreshing service 'Legacy_Module_15_SP4_x86_64'.
    Refreshing service 'Python_3_Module_15_SP4_x86_64'.
    Refreshing service 'SUSE_Linux_Enterprise_Server_15_SP4_x86_64'.
    Refreshing service 'SUSE_Package_Hub_15_SP4_x86_64'.
    Refreshing service 'Server_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Web_and_Scripting_Module_15_SP4_x86_64'.
    Loading repository data...
    Reading installed packages...
    'python3-bleach' is already installed.
    No update candidate for 'python3-bleach-3.1.5-bp154.1.95.noarch'. The highest available version is already installed.
    Resolving package dependencies...
    Nothing to do.
    pip installing...
    Installing GMS rpms...
    rpms installed successfully
    checking logrotate configuration...
    Should update logrotate settings: True
    0
    checking cheroot makefile...
    checking cheroot wsgi...
    checking cheroot server...
    checking cheroot threadpool...
    checking _pyio.py...
    GroupWise Administration host: gw1a
    GroupWise Administration port: 9710
    GroupWise Administrator user name: admin
    Please check the entries and try again
    GroupWise Administration host: gw1a.muekno.de
    GroupWise Administration port: 9710
    GroupWise Administrator user name: admin
    Please check the entries and try again

    </code>

  • Thanks but GWWEB and even the Old WebAccess as the GW Clients runs fine, login to the admin console too

  • Everything installed double checked

  • So one problem solved but another still exists

    I trough the server away installed a complete new one with only the modules requested. Got the latest updates and and installed the mobility services.

    That installed a lot of python but runs without error till asking to admin server etc.

    then I got the error:

    "Problem validating GroupWise server and credentials. Exception: HTTPSConnectionPool(host='gw1a.muekno.de', port=9710): Max retries exceeded with url: /gwadmin-service/domains?domainType=primary (Caused by SSLError(SSLError(1, '[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:852)'),))
    Failed to validate GW Admin"

    OK as I wrote I replace the admin certs to my own certs signed by my own CA, to get rid of browser warnings when accessing the consols.

    the certificate looks like:

    Allgemeiner Name (CN)
    gw1a.muekno.de
    Organisation (O)
    IB Mueller-Knoche
    Organisationseinheit (OU)
    IT

    Ausgestellt von

    Allgemeiner Name (CN)
    Ing Buero Mueller-Knoche
    Organisation (O)
    Ing Buero Mueller-Knoche
    Organisationseinheit (OU)
    Ing Buero Mueller-Knoche

    Gültigkeitsdauer

    Ausgestellt am
    Sonntag, 4. Dezember 2022 um 17:49:16
    Gültig bis
    Montag, 4. Dezember 2023 um 17:49:16

    Fingerabdrücke

    SHA-256-Fingerabdruck
    78 10 56 67 5B 67 02 12 C0 E0 4A A2 AC 79 8E F6 FF 45 58 17 EF AE 26 BD B9 BD A6 4F EA 95 B3 C5
    SHA-1-Fingerabdruck
    74 96 46 75 12 F2 86 66 94 E3 E0 B9 13 F6 B0 36 A1 64 B9 2F
    Every browser I install the CA.crt accepts this as vallid
    The cert and key are under "/opt/novell/groupwise/certificates/5C2D4EA0-180B-0000-BA79-1500DA000D00/admin/"
    I asume mobility service install looks there. So  I added my ca.crt to "/var/lib/ca-certificates/pem/" where all the other CAs are.
    ButI get the same error.
    What I do GroupWise requets a lot of Certificates but makes its nearly impossible to use offical certificates and there no iformation who to do it.
    So ifyout want to eccess Webaccess oderGWWEB or mobility services only via proxys wit LE certficates to enable user access vi a trusted certificate without to work around browser or otherclient warning
    Rainer 
  • Thanks that was the clue. I replaced the existing gwadmin_ca.pem with my CA crt under then same name and connection work, Now installation ist complet

  • sorry notfinished

    Istallation worked,

    gms status

    datasync-monitorengine.service active
    datasync-configengine.service active
    datasync-syncengine.service active
    datasync-webadmin.service active
    datasync-connectors.service active
    datasync-gwnotification.service active

    but port 8120, 5200 not open

    /var/log/datasync has only install log

    cannot access GMS console

    restart changed nothing

    restart of GMS did not help

    internet research, found nothing relevant

  • firewall settings?

    ________________________

    Andy of KonecnyConsulting.ca in Toronto
    Please use the "Like" and/or "Verified Answers" as appropriate as that helps us all.

  • nope host, worksation  everything in the same local LAN

  • But is there a local firewall active?


    Use "Verified Answers" if your problem/issue has been solved!

  • No local or internal firewalls active, just checked in yast  firewall = inactive, no start on boot.

    The one and only firewall is on the internet router.

    GMS status looks ok, but neither port 8120 for console. port 4500 for receiving from PO, nor 80 or 443 are open. SOAP port secure on POA is open and works fine with GWWEB running on an other server as well as GW WebAccess

    Stop and start GMS no change

    Is there anything I can check or look for.

    Configuration gw1 = primary domain, po  and gwia

    gw2 secondary domain gwweb and webaccess

    gw3 gms (new setup yesterday following strict gms recomotation

    all server sles 15 sp4 latest patches groupwise 18.4.2

    gms 18.4.1 as of a specific reason

Reply
  • No local or internal firewalls active, just checked in yast  firewall = inactive, no start on boot.

    The one and only firewall is on the internet router.

    GMS status looks ok, but neither port 8120 for console. port 4500 for receiving from PO, nor 80 or 443 are open. SOAP port secure on POA is open and works fine with GWWEB running on an other server as well as GW WebAccess

    Stop and start GMS no change

    Is there anything I can check or look for.

    Configuration gw1 = primary domain, po  and gwia

    gw2 secondary domain gwweb and webaccess

    gw3 gms (new setup yesterday following strict gms recomotation

    all server sles 15 sp4 latest patches groupwise 18.4.2

    gms 18.4.1 as of a specific reason

Children