This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Groupwise mobility service fails installation 18.4.2

see subject. many tries and hours of research but no succsess. 

After entering host admin etc. I get AttributeError: module 'lib' has no attribute 'OpenSSL_add_all_algorithms'

and asking starts again GroupWise Administration Agent hostname 

Please help

Rainer

Parents
  • This gives very little info so make sure the SLES modules/extension as mentioned in the requirements are installed, the server itself is registered and the GW admin certificates are all correct. Otherwise provide more details as OS/service pack used, GMS version and build you trying to install etc.

  • Thanks for answer my config is:

    NAME="SLES"
    VERSION="15-SP4"
    VERSION_ID="15.4"
    PRETTY_NAME="SUSE Linux Enterprise Server 15 SP4"
    ID="sles"
    ID_LIKE="suse"
    ANSI_COLOR="0;32"
    CPE_NAME="cpe:/o:suse:sles:15:sp4"

    + latest patches

    GroupWise is 18.4.2

    Mobility is groupwise-mobility-service-18.4.2-x86_64.iso

    Required modules installed

    Certificates should be ok, the admin console has commercial certificates to eliminate browser warnings

    Following the install log file:

    <code>

    Starting GMS install: Wed Jan 4 09:01:13 CET 2023
    GroupWise Administration host: gw1a.muekno.de
    GroupWise Administration port: 9710
    GroupWise Administrator user name: admin
    Please check the entries and try again
    Starting GMS install: Wed Jan 4 09:04:31 CET 2023
    NEW INSTALL
    Installing postgreSQL...
    Refreshing service 'Basesystem_Module_15_SP4_x86_64'.
    Refreshing service 'Certifications_Module_15_SP4_x86_64'.
    Refreshing service 'Containers_Module_15_SP4_x86_64'.
    Refreshing service 'Desktop_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Development_Tools_Module_15_SP4_x86_64'.
    Refreshing service 'Legacy_Module_15_SP4_x86_64'.
    Refreshing service 'Python_3_Module_15_SP4_x86_64'.
    Refreshing service 'SUSE_Linux_Enterprise_Server_15_SP4_x86_64'.
    Refreshing service 'SUSE_Package_Hub_15_SP4_x86_64'.
    Refreshing service 'Server_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Web_and_Scripting_Module_15_SP4_x86_64'.
    Loading repository data...
    Reading installed packages...
    'postgresql-server' is already installed.
    No update candidate for 'postgresql-server-15-150400.4.6.2.noarch'. The highest available version is already installed.
    Resolving package dependencies...
    Nothing to do.
    Refreshing service 'Basesystem_Module_15_SP4_x86_64'.
    Refreshing service 'Certifications_Module_15_SP4_x86_64'.
    Refreshing service 'Containers_Module_15_SP4_x86_64'.
    Refreshing service 'Desktop_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Development_Tools_Module_15_SP4_x86_64'.
    Refreshing service 'Legacy_Module_15_SP4_x86_64'.
    Refreshing service 'Python_3_Module_15_SP4_x86_64'.
    Refreshing service 'SUSE_Linux_Enterprise_Server_15_SP4_x86_64'.
    Refreshing service 'SUSE_Package_Hub_15_SP4_x86_64'.
    Refreshing service 'Server_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Web_and_Scripting_Module_15_SP4_x86_64'.
    Loading repository data...
    Reading installed packages...
    'postgresql-contrib' is already installed.
    No update candidate for 'postgresql-contrib-15-150400.4.6.2.noarch'. The highest available version is already installed.
    Resolving package dependencies...
    Nothing to do.
    Installing ImageMagick...
    Refreshing service 'Basesystem_Module_15_SP4_x86_64'.
    Refreshing service 'Certifications_Module_15_SP4_x86_64'.
    Refreshing service 'Containers_Module_15_SP4_x86_64'.
    Refreshing service 'Desktop_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Development_Tools_Module_15_SP4_x86_64'.
    Refreshing service 'Legacy_Module_15_SP4_x86_64'.
    Refreshing service 'Python_3_Module_15_SP4_x86_64'.
    Refreshing service 'SUSE_Linux_Enterprise_Server_15_SP4_x86_64'.
    Refreshing service 'SUSE_Package_Hub_15_SP4_x86_64'.
    Refreshing service 'Server_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Web_and_Scripting_Module_15_SP4_x86_64'.
    Loading repository data...
    Reading installed packages...
    'ImageMagick' is already installed.
    No update candidate for 'ImageMagick-7.1.0.9-150400.6.9.1.x86_64'. The highest available version is already installed.
    Resolving package dependencies...
    Nothing to do.
    Installing python-openssl...
    Refreshing service 'Basesystem_Module_15_SP4_x86_64'.
    Refreshing service 'Certifications_Module_15_SP4_x86_64'.
    Refreshing service 'Containers_Module_15_SP4_x86_64'.
    Refreshing service 'Desktop_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Development_Tools_Module_15_SP4_x86_64'.
    Refreshing service 'Legacy_Module_15_SP4_x86_64'.
    Refreshing service 'Python_3_Module_15_SP4_x86_64'.
    Refreshing service 'SUSE_Linux_Enterprise_Server_15_SP4_x86_64'.
    Refreshing service 'SUSE_Package_Hub_15_SP4_x86_64'.
    Refreshing service 'Server_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Web_and_Scripting_Module_15_SP4_x86_64'.
    Loading repository data...
    Reading installed packages...
    'python3-pyOpenSSL' is already installed.
    No update candidate for 'python3-pyOpenSSL-21.0.0-150400.3.3.1.noarch'. The highest available version is already installed.
    Resolving package dependencies...
    Nothing to do.
    Installing openssl...
    Refreshing service 'Basesystem_Module_15_SP4_x86_64'.
    Refreshing service 'Certifications_Module_15_SP4_x86_64'.
    Refreshing service 'Containers_Module_15_SP4_x86_64'.
    Refreshing service 'Desktop_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Development_Tools_Module_15_SP4_x86_64'.
    Refreshing service 'Legacy_Module_15_SP4_x86_64'.
    Refreshing service 'Python_3_Module_15_SP4_x86_64'.
    Refreshing service 'SUSE_Linux_Enterprise_Server_15_SP4_x86_64'.
    Refreshing service 'SUSE_Package_Hub_15_SP4_x86_64'.
    Refreshing service 'Server_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Web_and_Scripting_Module_15_SP4_x86_64'.
    Loading repository data...
    Reading installed packages...
    'openssl' is already installed.
    No update candidate for 'openssl-1.1.1l-150400.1.5.noarch'. The highest available version is already installed.
    Resolving package dependencies...
    Nothing to do.
    Installing python-lxml...
    Refreshing service 'Basesystem_Module_15_SP4_x86_64'.
    Refreshing service 'Certifications_Module_15_SP4_x86_64'.
    Refreshing service 'Containers_Module_15_SP4_x86_64'.
    Refreshing service 'Desktop_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Development_Tools_Module_15_SP4_x86_64'.
    Refreshing service 'Legacy_Module_15_SP4_x86_64'.
    Refreshing service 'Python_3_Module_15_SP4_x86_64'.
    Refreshing service 'SUSE_Linux_Enterprise_Server_15_SP4_x86_64'.
    Refreshing service 'SUSE_Package_Hub_15_SP4_x86_64'.
    Refreshing service 'Server_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Web_and_Scripting_Module_15_SP4_x86_64'.
    Loading repository data...
    Reading installed packages...
    'python3-lxml' is already installed.
    No update candidate for 'python3-lxml-4.7.1-150200.3.10.1.x86_64'. The highest available version is already installed.
    Resolving package dependencies...
    Nothing to do.
    Installing python3-psycopg2...
    Refreshing service 'Basesystem_Module_15_SP4_x86_64'.
    Refreshing service 'Certifications_Module_15_SP4_x86_64'.
    Refreshing service 'Containers_Module_15_SP4_x86_64'.
    Refreshing service 'Desktop_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Development_Tools_Module_15_SP4_x86_64'.
    Refreshing service 'Legacy_Module_15_SP4_x86_64'.
    Refreshing service 'Python_3_Module_15_SP4_x86_64'.
    Refreshing service 'SUSE_Linux_Enterprise_Server_15_SP4_x86_64'.
    Refreshing service 'SUSE_Package_Hub_15_SP4_x86_64'.
    Refreshing service 'Server_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Web_and_Scripting_Module_15_SP4_x86_64'.
    Loading repository data...
    Reading installed packages...
    'python3-psycopg2' is already installed.
    No update candidate for 'python3-psycopg2-2.8.5-5.7.1.x86_64'. The highest available version is already installed.
    Resolving package dependencies...
    Nothing to do.
    Refreshing service 'Basesystem_Module_15_SP4_x86_64'.
    Refreshing service 'Certifications_Module_15_SP4_x86_64'.
    Refreshing service 'Containers_Module_15_SP4_x86_64'.
    Refreshing service 'Desktop_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Development_Tools_Module_15_SP4_x86_64'.
    Refreshing service 'Legacy_Module_15_SP4_x86_64'.
    Refreshing service 'Python_3_Module_15_SP4_x86_64'.
    Refreshing service 'SUSE_Linux_Enterprise_Server_15_SP4_x86_64'.
    Refreshing service 'SUSE_Package_Hub_15_SP4_x86_64'.
    Refreshing service 'Server_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Web_and_Scripting_Module_15_SP4_x86_64'.
    Loading repository data...
    Reading installed packages...
    'patch' is already installed.
    No update candidate for 'patch-2.7.6-150000.5.3.1.x86_64'. The highest available version is already installed.
    Resolving package dependencies...
    Nothing to do.
    Refreshing service 'Basesystem_Module_15_SP4_x86_64'.
    Refreshing service 'Certifications_Module_15_SP4_x86_64'.
    Refreshing service 'Containers_Module_15_SP4_x86_64'.
    Refreshing service 'Desktop_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Development_Tools_Module_15_SP4_x86_64'.
    Refreshing service 'Legacy_Module_15_SP4_x86_64'.
    Refreshing service 'Python_3_Module_15_SP4_x86_64'.
    Refreshing service 'SUSE_Linux_Enterprise_Server_15_SP4_x86_64'.
    Refreshing service 'SUSE_Package_Hub_15_SP4_x86_64'.
    Refreshing service 'Server_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Web_and_Scripting_Module_15_SP4_x86_64'.
    Loading repository data...
    Reading installed packages...
    'wget' is already installed.
    No update candidate for 'wget-1.20.3-150000.3.15.1.x86_64'. The highest available version is already installed.
    Resolving package dependencies...
    Nothing to do.
    Refreshing service 'Basesystem_Module_15_SP4_x86_64'.
    Refreshing service 'Certifications_Module_15_SP4_x86_64'.
    Refreshing service 'Containers_Module_15_SP4_x86_64'.
    Refreshing service 'Desktop_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Development_Tools_Module_15_SP4_x86_64'.
    Refreshing service 'Legacy_Module_15_SP4_x86_64'.
    Refreshing service 'Python_3_Module_15_SP4_x86_64'.
    Refreshing service 'SUSE_Linux_Enterprise_Server_15_SP4_x86_64'.
    Refreshing service 'SUSE_Package_Hub_15_SP4_x86_64'.
    Refreshing service 'Server_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Web_and_Scripting_Module_15_SP4_x86_64'.
    Loading repository data...
    Reading installed packages...
    'dialog' is already installed.
    No update candidate for 'dialog-1.3-3.3.7.x86_64'. The highest available version is already installed.
    Resolving package dependencies...
    Nothing to do.
    Refreshing service 'Basesystem_Module_15_SP4_x86_64'.
    Refreshing service 'Certifications_Module_15_SP4_x86_64'.
    Refreshing service 'Containers_Module_15_SP4_x86_64'.
    Refreshing service 'Desktop_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Development_Tools_Module_15_SP4_x86_64'.
    Refreshing service 'Legacy_Module_15_SP4_x86_64'.
    Refreshing service 'Python_3_Module_15_SP4_x86_64'.
    Refreshing service 'SUSE_Linux_Enterprise_Server_15_SP4_x86_64'.
    Refreshing service 'SUSE_Package_Hub_15_SP4_x86_64'.
    Refreshing service 'Server_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Web_and_Scripting_Module_15_SP4_x86_64'.
    Loading repository data...
    Reading installed packages...
    'logrotate' is already installed.
    No update candidate for 'logrotate-3.18.1-150400.3.7.1.x86_64'. The highest available version is already installed.
    Resolving package dependencies...
    Nothing to do.
    Installing python3-requests...
    Refreshing service 'Basesystem_Module_15_SP4_x86_64'.
    Refreshing service 'Certifications_Module_15_SP4_x86_64'.
    Refreshing service 'Containers_Module_15_SP4_x86_64'.
    Refreshing service 'Desktop_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Development_Tools_Module_15_SP4_x86_64'.
    Refreshing service 'Legacy_Module_15_SP4_x86_64'.
    Refreshing service 'Python_3_Module_15_SP4_x86_64'.
    Refreshing service 'SUSE_Linux_Enterprise_Server_15_SP4_x86_64'.
    Refreshing service 'SUSE_Package_Hub_15_SP4_x86_64'.
    Refreshing service 'Server_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Web_and_Scripting_Module_15_SP4_x86_64'.
    Loading repository data...
    Reading installed packages...
    'python3-requests' is already installed.
    No update candidate for 'python3-requests-2.24.0-1.24.noarch'. The highest available version is already installed.
    Resolving package dependencies...
    Nothing to do.
    Installing python3-aniso8601...
    Refreshing service 'Basesystem_Module_15_SP4_x86_64'.
    Refreshing service 'Certifications_Module_15_SP4_x86_64'.
    Refreshing service 'Containers_Module_15_SP4_x86_64'.
    Refreshing service 'Desktop_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Development_Tools_Module_15_SP4_x86_64'.
    Refreshing service 'Legacy_Module_15_SP4_x86_64'.
    Refreshing service 'Python_3_Module_15_SP4_x86_64'.
    Refreshing service 'SUSE_Linux_Enterprise_Server_15_SP4_x86_64'.
    Refreshing service 'SUSE_Package_Hub_15_SP4_x86_64'.
    Refreshing service 'Server_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Web_and_Scripting_Module_15_SP4_x86_64'.
    Loading repository data...
    Reading installed packages...
    'python3-aniso8601' is already installed.
    No update candidate for 'python3-aniso8601-9.0.1-bp154.1.28.noarch'. The highest available version is already installed.
    Resolving package dependencies...
    Nothing to do.
    Installing python3-networkx...
    Refreshing service 'Basesystem_Module_15_SP4_x86_64'.
    Refreshing service 'Certifications_Module_15_SP4_x86_64'.
    Refreshing service 'Containers_Module_15_SP4_x86_64'.
    Refreshing service 'Desktop_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Development_Tools_Module_15_SP4_x86_64'.
    Refreshing service 'Legacy_Module_15_SP4_x86_64'.
    Refreshing service 'Python_3_Module_15_SP4_x86_64'.
    Refreshing service 'SUSE_Linux_Enterprise_Server_15_SP4_x86_64'.
    Refreshing service 'SUSE_Package_Hub_15_SP4_x86_64'.
    Refreshing service 'Server_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Web_and_Scripting_Module_15_SP4_x86_64'.
    Loading repository data...
    Reading installed packages...
    'python3-networkx' is already installed.
    No update candidate for 'python3-networkx-2.0-3.2.8.noarch'. The highest available version is already installed.
    Resolving package dependencies...
    Nothing to do.
    Installing python3-bleach...
    Refreshing service 'Basesystem_Module_15_SP4_x86_64'.
    Refreshing service 'Certifications_Module_15_SP4_x86_64'.
    Refreshing service 'Containers_Module_15_SP4_x86_64'.
    Refreshing service 'Desktop_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Development_Tools_Module_15_SP4_x86_64'.
    Refreshing service 'Legacy_Module_15_SP4_x86_64'.
    Refreshing service 'Python_3_Module_15_SP4_x86_64'.
    Refreshing service 'SUSE_Linux_Enterprise_Server_15_SP4_x86_64'.
    Refreshing service 'SUSE_Package_Hub_15_SP4_x86_64'.
    Refreshing service 'Server_Applications_Module_15_SP4_x86_64'.
    Refreshing service 'Web_and_Scripting_Module_15_SP4_x86_64'.
    Loading repository data...
    Reading installed packages...
    'python3-bleach' is already installed.
    No update candidate for 'python3-bleach-3.1.5-bp154.1.95.noarch'. The highest available version is already installed.
    Resolving package dependencies...
    Nothing to do.
    pip installing...
    Installing GMS rpms...
    rpms installed successfully
    checking logrotate configuration...
    Should update logrotate settings: True
    0
    checking cheroot makefile...
    checking cheroot wsgi...
    checking cheroot server...
    checking cheroot threadpool...
    checking _pyio.py...
    GroupWise Administration host: gw1a
    GroupWise Administration port: 9710
    GroupWise Administrator user name: admin
    Please check the entries and try again
    GroupWise Administration host: gw1a.muekno.de
    GroupWise Administration port: 9710
    GroupWise Administrator user name: admin
    Please check the entries and try again

    </code>

  • I got the exact same errors trying to install a new GMS server last night.  I installed SLES 15SP4, let it install all the updates during the installation, and then tried to install GMS 18.4.2 and I got no further than all those Python errors, ending with that same "module 'lib' has no attribute 'OpenSSL_add_all_algorithms'".  Trying to re-run install.sh was even worse, python errors all over the place.

    Not even a whole month ago I installed a new GMS server with SLES 15SP4 and GMS 18.4.2 exactly the same way, didn't have any of these problems... all I had to do was downgrade CHEROOT to 8.6 to get the dashboard to populate reliably.

    Are we saying now I need to remove Python 3.6 before I start installing GMS?  I thought GMS was the one installing Python 3.6?

  • Regarding the initial installation error, I can confirm that I experienced the same problem on newly build SLES 15 SP4 (plus channel updates) + GMS 18.4.2 server.    As suggested above, I removed python modules via "zypper rm phyton3", then relaunched the GMS installer.  This time it worked fine and let me proceed with the installation. 

    I'm a little confused about the rest of the points in this thread, I don't see anything that looks like a certificate issue or proxy issue. This seems to be simply an installation problem due to what is probably a conflicting python rpm.

    Note the PIP issue that is addressed in this tid was also an issue but they don't seem to be related: portal.microfocus.com/.../KM000012369

  • So the python issue seems to be a general problem and not only mine. For the certificates problem, that my caused  through my replacement of the GW Admin certs with my own trusted ones to omit browser warnings.

    What the mentioned TID concerns, I had this problem on one of my early partly successfull when replaceing certificates with own ones, but resulting in not be able connecting with mobile devices. In last successfull installation no problems with the console, I am useing Chrome on my OS X iMAC.

  • ok, I did the same and it worked:

    zypper rm python3

    /mnt/install.sh

    gms stop

    pip uninstall cheroot

    pip install cheroot==8.6.0

    gms start

    all appears well.

  • So there are a few questions here:

    1. Why does SLES15SP4 apparently now install Python3 by default, especially even without the matching Python Module added?

    2. Why, for the sake of it, can't Microfocus get their act together and finally learn universally how to properly install software on SUSE/Linux? (Hint: It has something to do with using repositories vs. just dumping (often conflicting with the OS) RPMs by scripts into the system, totally outside of any OS management). In doubt, ask the OES team how to do it, they seem to be the only ones with that knowledge left @Microfocus.

    3. Can we do away with SSL please, and invent something that works and doesn't drive everybody insane? (Partly kidding)
    More seriously: Insisting on 100% "proper" certificates on one hand, while at the same time not supporting replacing the admin! interface certificate (yes, that's the case, it's not officially supported) is not really helping.

  • I understand it may be meaningfull in a lot of envioremnets to secure internal groupwise communication by SSL, but is should be an option for the user and not enfored especially by intransparent GW internal CA and certificates. And if there should be more documentation about, so i.e. the hint to import the GW CA into the browser to suppress nerving browser warnings for admin users, or whow to propper replace the GW CA  

  •   - be assured that I will share your input with the GroupWise product team!

    OpenText Community Manager
    If you found this post useful, give it a “Like” or click on "Verify Answer" under the "More" button

  • Would someone take a look at this tid and see if it solves the issue for you.  If it does, we have an FTF build of Mobility that makes these steps no longer necessary - portal.microfocus.com/.../KM000010631

  • The problem in this thread was a new instal from scratch that hang (loop) at the point login into GW Admin. seems to be the same python module that makes the problem, but cannot verify this

  • All - We do have a new FTF build of GMS that should resolve these python install issues.  You will need to open a case but please do and ask for build 987 or newer.

Reply Children