This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Groupwise mobility service fails installation 18.4.2

see subject. many tries and hours of research but no succsess. 

After entering host admin etc. I get AttributeError: module 'lib' has no attribute 'OpenSSL_add_all_algorithms'

and asking starts again GroupWise Administration Agent hostname 

Please help

Rainer

  • Thanks but GWWEB and even the Old WebAccess as the GW Clients runs fine, login to the admin console too

  • Everything installed double checked

  • So one problem solved but another still exists

    I trough the server away installed a complete new one with only the modules requested. Got the latest updates and and installed the mobility services.

    That installed a lot of python but runs without error till asking to admin server etc.

    then I got the error:

    "Problem validating GroupWise server and credentials. Exception: HTTPSConnectionPool(host='gw1a.muekno.de', port=9710): Max retries exceeded with url: /gwadmin-service/domains?domainType=primary (Caused by SSLError(SSLError(1, '[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:852)'),))
    Failed to validate GW Admin"

    OK as I wrote I replace the admin certs to my own certs signed by my own CA, to get rid of browser warnings when accessing the consols.

    the certificate looks like:

    Allgemeiner Name (CN)
    gw1a.muekno.de
    Organisation (O)
    IB Mueller-Knoche
    Organisationseinheit (OU)
    IT

    Ausgestellt von

    Allgemeiner Name (CN)
    Ing Buero Mueller-Knoche
    Organisation (O)
    Ing Buero Mueller-Knoche
    Organisationseinheit (OU)
    Ing Buero Mueller-Knoche

    Gültigkeitsdauer

    Ausgestellt am
    Sonntag, 4. Dezember 2022 um 17:49:16
    Gültig bis
    Montag, 4. Dezember 2023 um 17:49:16

    Fingerabdrücke

    SHA-256-Fingerabdruck
    78 10 56 67 5B 67 02 12 C0 E0 4A A2 AC 79 8E F6 FF 45 58 17 EF AE 26 BD B9 BD A6 4F EA 95 B3 C5
    SHA-1-Fingerabdruck
    74 96 46 75 12 F2 86 66 94 E3 E0 B9 13 F6 B0 36 A1 64 B9 2F
    Every browser I install the CA.crt accepts this as vallid
    The cert and key are under "/opt/novell/groupwise/certificates/5C2D4EA0-180B-0000-BA79-1500DA000D00/admin/"
    I asume mobility service install looks there. So  I added my ca.crt to "/var/lib/ca-certificates/pem/" where all the other CAs are.
    ButI get the same error.
    What I do GroupWise requets a lot of Certificates but makes its nearly impossible to use offical certificates and there no iformation who to do it.
    So ifyout want to eccess Webaccess oderGWWEB or mobility services only via proxys wit LE certficates to enable user access vi a trusted certificate without to work around browser or otherclient warning
    Rainer 
  • Thanks that was the clue. I replaced the existing gwadmin_ca.pem with my CA crt under then same name and connection work, Now installation ist complet

  • sorry notfinished

    Istallation worked,

    gms status

    datasync-monitorengine.service active
    datasync-configengine.service active
    datasync-syncengine.service active
    datasync-webadmin.service active
    datasync-connectors.service active
    datasync-gwnotification.service active

    but port 8120, 5200 not open

    /var/log/datasync has only install log

    cannot access GMS console

    restart changed nothing

    restart of GMS did not help

    internet research, found nothing relevant

  • firewall settings?

    ________________________

    Andy of KonecnyConsulting.ca in Toronto
    Please use the "Like" and/or "Verified Answers" as appropriate as that helps us all.

  • nope host, worksation  everything in the same local LAN

  • But is there a local firewall active?


    Use "Verified Answers" if your problem/issue has been solved!

  • No local or internal firewalls active, just checked in yast  firewall = inactive, no start on boot.

    The one and only firewall is on the internet router.

    GMS status looks ok, but neither port 8120 for console. port 4500 for receiving from PO, nor 80 or 443 are open. SOAP port secure on POA is open and works fine with GWWEB running on an other server as well as GW WebAccess

    Stop and start GMS no change

    Is there anything I can check or look for.

    Configuration gw1 = primary domain, po  and gwia

    gw2 secondary domain gwweb and webaccess

    gw3 gms (new setup yesterday following strict gms recomotation

    all server sles 15 sp4 latest patches groupwise 18.4.2

    gms 18.4.1 as of a specific reason