This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

MAPI error accessing GroupWise Address Book

When I click on OK, the GroupWise client closes.

GroupWise Client 8.0.3 hp5

Relevant TIDs

Unable to access GroupWise address books

How to completely uninstall the GroupWise Client

The Details

I'm deploying new Windows 10 workstations for a customer to replace old Windows 7 computers. I installed GroupWise: gw8.0.3hp5_client_win_en.exe. Yes, the server is still NetWare but the GW 8 client runs fine on Windows 10. Then I installed Microsoft Office Home & Business 2019 on some computers, Microsoft Office Home & Business 2021 and Microsoft Publisher 2021 on others. 

After the Microsoft Office products were installed, only some of the computers experienced this MAPI error. 

  • It does not appear to be related to a specific version of Office or whether Publisher is installed.
  • On the affected computers the error exists on all Windows profiles and all GroupWise accounts.
  • Windows Updates have been installed before and after these products were initially installed.

I have uninstalled the GroupWise client and Office, restarted the system, then reinstalled them (multiple times): Sometimes GW first; sometimes Office first. The error persists!

I next thing I wanted to try was gwCleanIt or the microsoft online fix it utility  mentioned in the above TIDs but they no longer appear to be available.

At the moment, a newer version of GroupWise is not an option.

Suggestions anyone?

__________
Kevin Boyle, 
Knowledge Partner

Calgary, Alberta, Canada

  • Hi Kevin, that is really a heavy request. I compare it to run an electric car but use wooden tires ...

    Have you tried to install wms.exe manually (directory client\win32\wms\nt\us)? In some way we have to recall ancient knowledge - I know there have been a bulk of knowledge articles around MAPI.


    Use "Verified Answers" if your problem/issue has been solved!

  • Hey Kevin,  you should have email now with CleanIt5.2.zip in it

    ________________________

    Andy of KonecnyConsulting.ca in Toronto
    Please use the "Like" and/or "Verified Answers" as appropriate as that helps us all.

  • Have you tried to install wms.exe manually (directory client\win32\wms\nt\us)?

    Yes, I uninstalled Windows NT Messaging when I uninstalled Office and the GroupWise client. After I reinstalled both products I tried installing wms from the directory you show. The error persists.

    Hey Kevin,  you should have email now with CleanIt5.2.zip in it

    Thanks, Andy. I'll try that now.

    __________
    Kevin Boyle, 
    Knowledge Partner

    Calgary, Alberta, Canada

  • Suggested Answer

    Hey Kevin,  you should have email now with CleanIt5.2.zip in it

    Thank you. I can now access the Address Book without encountering the MAPI error. Slight smile

    And now, for the rest of the story...

    For anyone else who finds themselves in a similar situation, This is what happened.

    I ran CleanIt. There is no documentation. The Help button links to a site that is inaccessible. There is also a Start button. I clicked it.

    I got a message saying the utility couldn't find where the GroupWise client was installed. Of course it couldn't! I had just uninstalled Office and the GroupWise client.Thinking

    I reinstalled the GroupWise client and tried again. The uninstall (cleanup) began. At about 40 percent complete, this happened: Scream

    I clicked Continue but got the same error. After a couple of more tries, I clicked Quit. I got another message telling me that if I quit now my system would be left in an inconsistent state. I had no choice: I quit. Unamused

    I tried to uninstall the GroupWise client from the Control Panel. I was offered the option to repair or uninstall. I chose uninstall. While uninstalling, this error was displayed: Open mouth

    I clicked OK then got the same error for the other GroupWise applications. The uninstalled completed but I had no idea what state the system was in.Worried

    I decided to reinstall the GroupWise client. What did I have to lose? The install completed so I tried to open the Address Book. It opened! Relieved

    Finally, I reinstalled Office. The GroupWise Address Book still opened. It appears that the issue has been resolved. Triumph

    Let's see if it survives the day tomorrow (Monday).

    By the way, I did have a restore point. Wink 

    __________
    Kevin Boyle, 
    Knowledge Partner

    Calgary, Alberta, Canada