GMS error during upgrade

I upgraded from 24.1 to 24.2 and this error ... 

Schema change: "CREATE OR REPLACE TRIGGER data_added AFTER INSERT ON mcheckitems FOR EACH ROW EXECUTE PROCEDURE notify_id_trigger();"
Failed to update database schema (1).
Error output = ERROR: syntax error at or near "TRIGGER"

Can't find anything usefull online. Table  mcheckitems was created. Function notify_id_trigger not.

Anyone had same problem ?

David

Tags:

  • i had no problem by upgrade from gms24.1 to gms24.2.

    Do you have open a case for this?

    How big is you gms server? my experience is to uninstall gms on this server, remove directories and make a fresh install, this will solve the most trouble.

    Then reconfigurue correctly the configuration and sync the devices, take a little time, but then your are on the sure side!

  • Hello David,

    I assume you tried to update more than once ...

    So did you return to version 24.1 to support your users?


    Use "Verified Answers" if your problem/issue has been solved!

  • Hi Diethmar, 

    no, I only did one attempt and because the table has name mcheckitems I assumed, that this is nothing critical and will open a case for it. 

    • User Check enhancement: When you run MCheck option 2. Users > 1. Check User, the check will now trigger the Mobility Server to recover missing items, rather than force a full Re-Initialization of the user’s account.

      For more information, see the MCheck section of the GroupWise Mobility Service Administration Guide.

    David

  • David,

    maybe try it more than one time. We never know who created the install script after a long day of development  Innocent.

    If there is a small issue after patching the server or restarting gms, I tried to re-install. And many times it helped.

    However I understand that it is not an option to uninstall and install a new gms. It is not easy to explain your users and your users will lose some settings..


    Use "Verified Answers" if your problem/issue has been solved!

  • Will try to reinstall it, thanks for hint. 

    David

  • I got newer GMS version from support and did update, but that doesn't fixed the problem with updating of the DB schema. Still getting the error. Case opened, will see ... 

    David

  • Looks like I need help from community, I opened the case and tech support told me, that GMS PostgreSQL is not supported and I'm now on my own. I got multiple FTF versions of the GMS and error during upgrade is still the same. 

    It's very strange, that no one other got this error, even I have it on ALL my customers sites. 

    David

  • What a joke!

    Escalate this case!

    My GMS:

    postgresql.service - PostgreSQL database server
    Loaded: loaded (/usr/lib/systemd/system/postgresql.service; enabled; vendor preset: disabl>
    Active: active (running) since Thu 2024-05-09 14:34:57 CEST; 2 weeks 5 days ago
    Process: 1507 ExecStart=/usr/share/postgresql/postgresql-script start (code=exited, status=>
    Main PID: 1600 (postgres)
    Tasks: 97
    CGroup: /system.slice/postgresql.service
    ââ 1600 /usr/lib/postgresql13/bin/postgres -D /var/lib/pgsql/data
    ââ 1688 "postgres: logger " "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" >
    ââ 2493 "postgres: checkpointer " "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" >
    ââ 2494 "postgres: background writer " "" "" "" "" "" "" "" "" "" "" "" "" "" "" ">
    ââ 2495 "postgres: walwriter " "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" >
    ââ 2496 "postgres: autovacuum launcher " "" "" "" "" "" "" "" "" "" "" "" "" "" "">
    ââ 2497 "postgres: stats collector " "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" >
    ââ 2498 "postgres: logical replication launcher " "" "" "" "" "" "" "" "" "" "" "">
    ââ 7287 "postgres: datasync_user mobility 127.0.0.1(52960) idle" "" "" ""
    ââ 7288 "postgres: datasync_user mobility 127.0.0.1(52970) idle" "" "" ""
    ââ 7289 "postgres: datasync_user datasync 127.0.0.1(52982) idle" "" "" ""
    ââ 7290 "postgres: datasync_user datasync 127.0.0.1(52988) idle" "" "" ""
    ââ 7312 "postgres: datasync_user dsmonitor 127.0.0.1(52994) idle" "" ""
    ââ 7313 "postgres: datasync_user dsmonitor 127.0.0.1(53006) idle" "" ""
    ââ 7314 "postgres: datasync_user dsmonitor 127.0.0.1(53022) idle" "" ""
    ââ 7315 "postgres: datasync_user dsmonitor 127.0.0.1(53026) idle" "" ""
    ââ 7316 "postgres: datasync_user dsmonitor 127.0.0.1(53030) idle" "" ""
    ââ 7317 "postgres: datasync_user mobility 127.0.0.1(53038) idle" "" "" ""
    ââ 7318 "postgres: datasync_user mobility 127.0.0.1(53054) idle" "" "" ""
    ââ 7319 "postgres: datasync_user mobility 127.0.0.1(53060) idle" "" "" ""
    ââ 7320 "postgres: datasync_user mobility 127.0.0.1(53064) idle" "" "" ""


    Use "Verified Answers" if your problem/issue has been solved!

  • Excellent advice, Diethmar.  David - I have taken ownership of case 02875864.  We do, absolutely, support this and I will find out who gave the front line person the infromation that we did not.  In the meantime, I will send you an email.  You should see if in a few minutes  -  Pam

  •  

    I see you have PGSQL version 13 and I have 12. Maybe this can cause the problem.

    David